When KDE 5.27.6+ for Leap 15.5?

I’m encountering a general bug of KDE 5.27 about after sleep awakening freezing. Did not count but maybe after 10-15+ sleep-awake cycle my sessions gets glitch-freezing effect, can’t use it till restart. I’d faced same issues when I was using other distros with KDE 5.27.

There was no any kind of issue when KDE was 5.24 so it’s directly related to current version of KDE. So wondering when bug-free versions of KDE will be available for Leap?

1 Like

You could try a bug report on this.

openSUSE:Submitting bug reports

You should report the problem to KDE.

1 Like

that’s already a known bug but as I know they have fixed with new releases. so I’ve asked when new KDE version.

Normally there will be no newer versions of software once a LEAP version is completed and tested (that is a basic philosophy of LEAP). But it could be that the fix will be retrofitted and appear in the Security and Recommended patches.

1 Like

The OP is likely using the KDE repos…

nope I stick with Leap releases.

Well if you upgrade via the KDE repos, it will receive the version of interest in the not too distant future.

I see but that will work stable?

It has for me (since years).

1 Like

FYI, I’ve just run an update, and currently at

  Host: linux-lptp1 Kernel: 5.14.21-150500.53-default arch: x86_64 bits: 64
    compiler: gcc v: 7.5.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.14.21-150500.53-default
    root=UUID=4ce18f23-7d51-4b5c-ba5a-447c5c33dd05 splash=silent
    preempt=full mitigations=auto quiet security=apparmor
  Desktop: KDE Plasma v: 5.27.5 tk: Qt v: 5.15.10 wm: kwin_wayland vt: 2
    dm: SDDM Distro: openSUSE Leap 15.5

KDE comes via backports and on entirely volunteer basis so here rules are not really that strong here. In any case, if it is fixed in some 5.27.NN release I do not see what would prevent update. But this would certainly require someone to submit bug report that contains problem description and pointer to upstream fix. Then it is up to openSUSE KDE maintainer to decide whether they would backport it, bump version or - can happen - close as won’t fix.


I installed the last KDE 5.27.6 using this:
KDE Argon
with these KDE repositries

1 Like

hmm but repos for 15.4 wont be problem for 15.5?

Check the repo definition (a file in “/etc/zypp/repos.d”). Does it use “15.4” or does it use “$releasever”. If the latter, you should be fine. Otherwise change it.

docs forward me to switch Leap to Tumbleweed :smiley:

I’m gonna observe the latest QT and KDE Plasma against sleep-awake black screen/freezing. At the moment TW works faster then Leap surprisingly.

Hope KDE will not produce this ridiculous issue after 15+ sleep-awake cycle. I’ll post my usage results here.


issue still persists after 20-25 sleep-awake cycle. It was working flawlessly with Leap 15.4 and it’s kernel so issue should be related to KDE + newer Kernel combo.



I have found exact reason of the bug what’s not directly related to KDE 5.27.4.or.6 but mostly kernel. Rollback to 15.4 first and tried with KDE 5.27.4 and kernel 5.14.21-150400.24.66 all was great no any post suspend black screen or freezing.

then tried multiversion kernel option on grub via docs

added 5.14.21-150400.24.66

multiversion.kernels = latest,5.14.21-150400.24.66 ,running

and then upgraded Leap 15.4 KDE to 15.5. So tried once again with new kernel which is 5.14.21-150500.53 and it caused sleep-awake black screen after 20+ cycle. Then I set default kernel to 5.14.21-150400.24.66 with KDE 5.27.4 and reproduced sleep-awake cycles 30+ for twice, no issue occured.

I updated my case for others what may help, or team can handle and find out what’s causing it.

se ya susers :+1:

If it worked in Leap 15.4 and stopped working in Leap 15.5 it is regression and you should report it in bugzilla: https://bugzilla.opensuse.org/. Same user/password as here, select Kernel component.

it also works with 15.5 but with previous/older 5.14.21-150400.24.66 kernel, 15.5 comes with an updated kernel which is 5.14.21-150500.53 that does not work. I think this newer+ kernels causing the bug coz I could not use in TW kernels too.

I’m gonna report bug as well.