What's wrong with wireless in OpenSUSE?

Hello Everyone,

My thread title sounds like a complaint, but it isn’t. I just have a question for my own education. I just started using OpenSUSE on an old laptop. It seems that I have my graphical problems at least temporarily solved, but I continued to lose my wireless connection after an hour of use. This is an old and well supported chipset (RT2500) and I had never had any issues with it before. I use WPA security, and one kind poster suggested I had a line for using the old “wext” driver in the /etc/sysconfig/ifcfg-wlan0 file, and that seems to have sorted it since I have not had any further issues since doing that edit. I eventually found the information on my own:

Note: This option requires a wpa driver supporting it, like

the ‘nl80211’ driver used by default since openSUSE 11.3.

When you notice problems with your hardware, please file a

bug report and set e.g. WIRELESS_WPA_DRIVER=‘wext’ (the old

default driver) in the ifcfg file.

See also “/usr/sbin/wpa_supplicant --help” for the list of

available wpa drivers.

As I look around this networking section of the forum, I can see a lot of similar issues with wireless and 11.3.

My question is: has OpenSUSE made some changes to the way wireless is configured or is it changes in the newer kernels (2.6.34 and above)?

Would just like to better educated myself about this in case of future issue or if I can help someone new.

Thanks for any replies.


HCL:Network (Wireless) - openSUSE

What is the output form

/sbin/lspci -nnk

Thanks for your reply, but the pertinent output from that command is:

0201] (rev 01)
Subsystem: Belkin F5D7010 Wireless G Notebook Network Card [1799:701a]
Kernel driver in use: rt2500pci

But this is information I provided in my opening post. I already knew what chipset I have and what driver was being used. My question was why has a chipset which has been supported by the kernel for so may years suddenly not working correctly with OpenSUSE 11.3? I was losing the wireless connection after about an hour of use until I edited the /etc/sysconfig/ifcfg-wlan0 file to add the “wext” driver for wpa_supplicant. Has OpenSUSE depricated this driver for wpa_supplicant?

Thank for you reply.


I seem to recall something about this recently. But I don’t know the answer/
Perhaps @lwfinger will know.

Thanks, but I spoke too soon. Shortly after writing this post, the network yet again disconntected. The network is still visible to NetworkManager when this happens, but it will not reconnect at all until I reboot.

I do not know at this point if it is related to wpa_supplicant or not, but this long supported chipset will not work consistently. IPv6 related? I have disable it. We’ll see. In the meantime, if anyone has any idea what logs to check when this happens, I would appreciate a clue.



I am pretty sure I have seen something on this device recently.
I’ll do some searches for you. Could be a blacklist that is required.

Well, if you do find something, I would be greatful. I have done a similar search and on the google-linux with nothing useful showing up. While it is working, it works great, excellent signal and speed. But when it goes down, nothing from the command line will bring it back. I have to reboot to get it working again.

Thanks again.


This a different device:
RaLink RT2860 not working out of thebox in opensuse 11.3
But you might want to consider trying ifup?!

Wireless driver initialized with NetworkManager, but not ifup
Belkin F5D8053 USB (Ralink rt2870 chipset) in openSUSE 11.3

I’ve been working with someone on bugzilla to try and resolve what may be a related issue. Don’t get your hopes up; nothing has worked so far. I have a pci card with the rtl8185 chip. When yast probes it, the computer locks up hard and I have to power off. After trying a dozen things, I noticed in one log that the freeze occurs when checking wpa-supplicant. I have no idea how to make use of this info. The card worked well right up through 11.1 and stopped the boot process in 11.2. Now, at 11.3, I can boot but can’t use the card.

Network manager is disabled. Can’t get far enough in yast to enable it and ifup doesn’t work; it says no configuration. Also, it switched this card to wlan1 for some reason. Sorry to hear wext didn’t work. But at least that is one thing I won’t have to try.

Thanks Prexy. I tried to use ifup but it wouldn’t connect at all with that method. It DOES connect automatically on boot and lasts for about 30 mins. When it suddenly disconnects, I run a diagnostic script and running that causes it to be invisible to NetworkManager. Nothing will get it to reconnect except a reboot. So, I am not sure if it is the same issue you are describing, but this is the first distro I have ever seen that did not handle this chipset with ease. It has been supported in Linux for years.

Hopefully, I can get this sorted, or I will have to revert back to an older distro which will handle the graphics chip as well (I still get a black screen on about every third reboot.) This old hardware just may not be able to handle such a modern distro.
The last distro I used which was continuously stable of Ubuntu 9.10. But that will be unsupported soon. I like OpenSUSE. Just ashame this machine won’t handle it.

For your issue, have you tried typing in a terminal:


Which should give you an applet in the tray which you can right click and edit.
Not sure if it will work with SUSE but always worked in other distros.

I tried the nm-applet and it didn’t work. I am using a usb dongle until this gets sorted out. But that means sharing it with another computer. It works well with ifup. I just don’t have that cute graph in the icon tray :wink:

I just read another thread where a problem similar to your was solved by changing the encryption at the router from wpa to wpa2. Might be worth a try.

Also, I’ll make a bet with you that I am using older, lower-powered, hardware than you yet it works well. Does the word “Coppermine” ring a bell? I did have to max out the ram (at 512 MB) to get a decent experience.

Also, I’ll make a bet with you that I am using older, lower-powered, hardware than you yet it works well. Does the word “Coppermine” ring a bell? I did have to max out the ram (at 512 MB) to get a decent experience.

Ah, the infamous Coppermine. I used one for years. As a matter of fact it was just last year that I finally donated that machine to a school. PIII with 512mb memory. It was probably one of the best running machines I ever had, and I built it myself from scraps from other computers (IBM workstation motherboard, Nvidia card and whatever else I could scrape up.) I still use a six year old AMD64 3200 with 1.5GB memory as my main desktop and it still flies with Ubuntu Lucid on it.

With regard to losing my connection, I can try to change the encryption on the router, but I am in fact using WPA instead of WPA2. My router supports it, so I will see what it does. The only issue is that I have a lot of other machines on my home network and I am not sure that all of them support WPA2. I will see how it goes.
Thanks for the tip.


I think that there is something wrong in the ( 80211 etc) code in the kernel . I have an atheros chip AR2425 (AR5001 Wireless Network Adapter) and it is doing the same thing. I have 11.2 working well on the same laptop as dual boot but in 11.3, there are constant disconnects and reconnects until it fails to reconnect after some time.

See this post -

wireless issues in the kernel (?!) in opensuse 11.3

It would seem that there are a lot of people experiencing similar issues. I hope that either a networking guru chimes in with a solution or the devs recognize the problem and come up with a patch.

This is the first time I have ever used OpenSUSE full time on a particular machine, and I find that I do like quite a lot. But, obviously networking is important and unless I can find a fix fairly soon, I am going to have to look at another distro for this laptop that will work with my wireless.


I’m just gonna throw in my two cents here. I have a laptop with an Atheros chipset that has out of the box support and works flawlessly every time. Come to think of it, I installed 11.2 on that machine and did an in-place dist upgrade to 11.3, so perhaps it wouldn’t work out of the box on 11.3.

I just got an entirely new machine and have tried three different wireless cards: Belkin USB F7D1101 with Rtl8192 chipset; Netgear WG311v3 with Marvell 88w8335 chipset; and Asus PCE-N13 with RaLink RT2860 chipset. Each of these products works fine on Windows. I use WPA2 and have not tried any of these cards with anything except WPA2 because they’re worthless to me without WPA2.

OpenSUSE could not use the Belkin whatsoever, with any native drivers or ndiswrapper. The Netgear got one step further; I was able to detect the wireless interface and scan, and twice it seemed like I actually got a working connection with ndiswrapper but this success did not persist on reboot.

The RT2860 seems to work out of the box. When trying to get the other two cards to work, I installed compat-wireless so it might be something in that that made it work. Even now it’s not perfect. It doesn’t always connect. It hangs on the “configuring interface” or “waiting for authentication” step (in KNetworkManager) that the Marvell hung on, except the Marvell would output essid or invalid cmd 12 error messages in the log, whereas the RT2860 doesn’t (yes I researched these errors but that’s not what this post is about). Every time I boot I have to wait for the authentication to time out twice before it connects.

However, using “traditional ifup method” allows me zero connectivity with the RT2860, although the card is detected.

Several years ago I used a USB RT7230 (if memory serves) and after a lot of work was able to use it with ifup and wpa_supplicant.

So what’s wrong with wireless in OpenSUSE? Vendors don’t want to support linux. Vendors don’t want to release hardware specs or firmware. Vendors especially don’t want to support 64-bit linux. (Realtek seems to be the one exception here) Most linux devs are doing it for fun, so if they want to quit working on something or can’t get something working, no one’s going to replace them. I’m sure that in 5 or 10 years wireless support in linux will be smooth, but for now it seems we are still in the “you might have to write your own drivers” stage. I would guess there’s probably errors in the kernel, errors in the firmware, and errors in the drivers that contribute to the giant wireless headache.

I don’t know if I mentioned it before, but the RT2500 I am using has worked flawlessly with three distros on this same laptop (and am currently dual booting with Puppy, which continues to work flawlessly.)

So, the issue is definitely with 11.3. Hope it is fixed soon.


The Belkin’s chip seems to be supported in the kernel, some other setting interfering? Reboot after changing driver? I recently used an rtl8192 USB device (not a Belkin though), worked OK.
RALINK RT2860 is supported
On the Netgear: if you get it working with ndiswrapper, and it does not persist on reboot, you need to ‘modprobe ndiswrapper’…

I’ve handled a lot of laptops and netbooks lately, have been surprised about the increased support on these machines. Main issue are the Broadcom based cards, but the driver is provided through the Packman repo, works like a charm.

Refer to this thread to get your Belkin NIC working. It’s not that difficult. I can assist you if you need it.
Need help with wireless adapter

Well…no. Many other distros (Ubuntu, Fedora) manage to get this stuff right. OpenSuSE, however, has serious problems with even the simplest of things, from wireless to sound to video, that other packages don’t suffer from at all.

You’re partially right - it’s all about support. The problem, however, seems to be that what support exists is migrating away from OpenSuSE and toward other distros that tend to get better with each release. Something that OpenSuSE once led at, but which has certainly not been true with the last couple releases. It’s been noted many times just in this thread that the OP is discussing hardware which has worked perfectly in earlier distros, and is now broken under 11.3.

I’ve used OpenSuSE for many years now, and the decline in quality has been precipitous over the last two years or so. I’ll be giving it one more shot with 11.4 - and I won’t upgrade if the forums are filled with complaints as they are now - but if installation is as painful as it has been for 11.2 and 11.3, I’m ready to move on.

It would be nice if developers and package maintainers from major distributions such as Debian, Ubuntu, Fedora and openSUSE get together once in a while to share notes, etc. and work on a common wireless hardware compatibility list, as well as a list of common linux wireless drivers. It does not make sense to re-invent the wheel. In Fedora, a user just need to install akmod package for a particular driver once, say Broadcom wl, then the driver gets updated automatically whenever there’s a kernel upgrade. Is there some way Fedora’s akmod packages, being rpm-based like openSUSE’s packages, can be ported over to openSUSE? if this is achievable, it would be a great help for users, especially newbies.