Whats the story with this UEFI stuff?

there is a tl;dr at bottom

So that’s kind of the situation, 3 MB’s so far from asus and all of them seem to have a lot of issues with Linux. This latest board, the M5A99FX.

I don’t know if there is a copy paste disclaimer about being a guy that doesn’t know what hes talking about. I have a little below average, but not total newb status, to the wonderful world of learning how to do things the right way, aka Linux

My partitioning plan for all of this is to make a 1GB sda ext3 /boot and the rest of it was an LVM containing a 20GB ext4 / and ~200gb vfat non-mounted

Now, the first thing I did was put in the opensuse cd and tell the MB to boot to it without uefi, everything installed fine, and in fact it did the first boot no problem. When I take the cd out I get the same old OS not found business.

Next I told the MB to boot the cd in UEFI, which as I understand uses elilo rather than grub, I thought what the heck, why not. Everything installs fine, I took the CD out, installed updates, reboot several times and finally get around to installing the xen hypervisor. I reboot, it goes straight to the login screen, uhmmm, aren’t we forgetting something? like kernel selection. So I did a few google searches and tried to use some tool to make my own xen kernel be the default, that dead ended at the first error because nearest I could tell my init.d file WAS there, despite the message.

Moving on, Fedora 17, HOLY ERRORS BATMAN, stuff crashing all over the place, re-download, check MD5 of iso and verify disk and re-install, same ****. I decide to continue just to see if I can get to the point that I can boot into xen. Fedora actually shows a kernel selection menu, I am able to boot up, I make a VM, passthrough the second graphics card and find out I forgot to make my LVM to include a vfat partition for a windows VM to use. At this point I could just go make that partition and continue with my mission, but this was an experiment and I didn’t intend to keep fedora because of the crashes, and I don’t like it.

Ubuntu wouldn’t even finish downloading dependencies for xen before kicking me back out to the shell, but it wasn’t showing the kernel selection either.

tl;dr Why do some distros seem to get past the UEFI thing and get to the kernel selection screen (fedora), but some wont even boot when installed without UEFI… does UEFI not let you select a kernel?

I understand I’m probably not going to get what I need out of this motherboard, but the main question here is “what do I need to look for in a modern MB to make sure that I get a gaming grade MB with full linux support?”

Hi
I’m using UEFI/elilo here with SLED and openSUSE. See the two forum
articles from user please_try_again (on page 3) for some good info.
http://forums.opensuse.org/content/?page=3


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.31-0.9-default
up 1:11, 2 users, load average: 0.05, 0.11, 0.17
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

Well, this is disheartening

my MB is the one marked with the little “no” under Linux UEFI

what do I search for that will make MB’s like this stand out, is there a cute little symbol of a middle finger with big bold letters “Linux” under it on the packaging?

Unfortunately this is going to get worse as manufacturers make more MS only motherboards.

Best to make your feeling known to the makers that put out this horse hokey. Maybe return the board as unsuitable.

In theory you should be able to turn off this nonsense in the BIOS.

Deffinitly going to write an email to asus. Unfortunatly I bought this set up at the same time as like 4 other computers for work here and there was so much left over trash i threw away everything including the box.

I don’t see any way to edit a post here, oh well. 40 minutes on phone with asus to get to level 2 support just so my complaint was well writen, I guess im a number now, yay.

thanks for the info, ill go through that grub2-efi install process anyway, even though its not supposed to work it will be fun.

If you follow the link to the post about your MB, you will see that the OP of this thread really tried everything … but if I remember correctly, he never got this mainboard to boot in UEFI mode (with Linux). Thus he never got to install grub2-efi nor elilo. If you manage, we will have to rewrite the story here. :wink:

More about ASUS M5A99X EVO and UEFI in this excellent post: http://forums.opensuse.org/english/get-technical-help-here/install-boot-login/472198-opensuse-12-1-uefi-install-64-bit-2.html#post2439860

That would be cool … because if you could turn it off, you could also turn it on and boot in UEFI mode (without having to call BIOS setup and change the boot priority every time with the install medium inserted to make sure that it boots in UEFI). The problem with this mainboard - as @fosdex described it - is that even if you give the UEFI boot device (such as openSUSE install DVD) boot priority, it will boot and install in legacy mode (i.e it will run Legacy Grub setup instead of ELILO).

RMnimbus wrote:
> my MB is the one marked with the little “no” under Linux UEFI
>
> what do I search for that will make MB’s like this stand out, is there
> a cute little symbol of a middle finger with big bold letters “Linux”
> under it on the packaging?

ROFL, ROFL, LOL Thanks for that concept.

Hi
As a followup, I took the liberty of adding it as an agenda item for
the next project meeting.
http://en.opensuse.org/openSUSE:Project_meeting#Agenda

Jump on IRC #opensuse-project on 27-June-2012 @ 2000 UTC and speak
up… :wink:


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.31-0.9-default
up 18:51, 3 users, load average: 0.41, 0.36, 0.28
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

I have read this thread with interest since I tried to follow what is going on with UEFI. I use several Asus laptops, the newest is a year old and I could install Opensuse without problems. Like gogalthorp and RMnimbus suggested I too wrote to Asus to complain, telling them if they don’t rectify the problem I will never buy one of their computers again. I hope more people will do this. I only got the following answer:

>Dear Valued Customer,
>
>Thank you for contacting ASUS Customer Service.
>
>We will consider your advice.

Of course that is just a quick reply which will change nothing, but if they would be swamped with emails complaining and telling them they will go somewhere else for their laptops in future they might consider a BIOS update allowing a Linux install.
Uli