Whats the new SaX2 command?

Tried doing SaX2 -r -m 0=fglrx but said it didnts exist anymore.

Whats the command for changing graphic drivers now?

For instance, if i wanted to change to radeon opensource?

If you are talking about openSUSE 11.3, then sax2 has been removed. I suggest you look at the following document and depending on the type of video card you are using, more help can be provided.

SDB:Configuring graphics cards - openSUSE

Thank You,

This is why I hoped there would be an antlernative, but no we didnt get such a thing.
So far the only thing that has anything lilke SAX anymore is Mandriva/Pclinux for those who feel auto configs dont do the job.
This sort of thing makes it harder to set up graphics drivers for sure.

So Xorg -configure is the only way. Alot harder to edit a file than just type SaX2 -r -m 0=radeon, etc.

Ill get to know the Vi editor then. :slight_smile:

i mourn the passing of sax2 also, a user-friendly tool that saved me countless hours.

ranks up there with the pulseaudio guy thinking that alsa would re-write all the drivers for compatibility with his cool software… somehow this does not compute, if we are taking steps forward, why doesn’t it feel like it?

I Agree , sax2 has saved me a lot of time.
For example I have installed opensuse 11.3 on a HP2133 (for this HP supports linux) netbook but now the resolution is not higher then 600x480.

I have also a HP2133 same problem resolution is not higher then 600x480 did you manage to get it higher?
Otherwise I think I am going back to Ubuntu which works right out of the box on my HP2133

I did a search for the HP2133 and could not find one request for help with the graphics, … mind you since the new forum format, the search engine has NOT been working well.

Still, did anyone start an HP2133 via graphics help thread ?

Did some search and found this software.opensuse.org: Zoekresultaten

It is A free and Open Source video driver for the VIA/S3G UniChrome, UniChrome Pro and Chrome9 graphics chipsets.
(CLE266, KM400/KN400/KM400A/P4M800, CN400/PM800/PN800/PM880, K8M800, CN700/VM800/P4M800Pro, CX700, P4M890, K8M890, P4M900/VN896/CN896, VX800, VX855)

Just choose one click install and then reboot the HP2133 works perfect for me.

Wireless was also not working for me so I installed bcm42 firmware :
sudo /usr/sbin/install_bcm43xx_firmware

Now it works
Have Fun enjoy openSUSE

As noted in many threads, sax2 was dropped because it had problems and could not be maintained.

If one is insistent on trying it, one can obtain sax2 for 11.3 currently on a user’s account on the build service (I don’t know how long it will stay there):


I confess to being skeptical that it will help, as a lot has changed in graphics since sax2’s ‘hey day’. … Apologies to all if I sound like a broken record on this.

There is no real need to use Vi. You could use Kwrite or something when you have a gui, or use Midnight Commander’s text editing capabilities when you are at the cli.