What to blame? Dolphin, Ark, FileDialogue, or...

What to blame? Dolphin, Ark, FileDialogue, or maybe just the phase of the moon…

KDE Frameworks 5.19.0 and Dolphin/Ark 15.12.2

In Dolphin navigate to a compressed file.
Right click on the file to open context menu.
Extract → Extract archive to…
From the file dialogue that opens, navigate to a directory.
Right click on directory/file listing to open context menu. (For example, to create new directory).

Whoops… context menu opens and hangs.
Mouse cursor moves… but that’s about all.

ctrl-alt-f* to a virtual terminal seems the only way out.

OK… On further testing. I think we can eliminate Dolphin as basically the same happens if Ark is used to open the compressed file directly.

Sounds a bit like https://bugzilla.opensuse.org/show_bug.cgi?id=957006 which was caused by a bug in Qt5.
(the bug report is about dolphin, but the same applied to the file open/save dialog)

A fix should be in Tumbleweed already since a few days though.
Is your system up-to-date?
What exact version of libQt5Core5 do you have installed?

Similar, possibly. I’ll take a better look at those tomorrow.

A fix should be in Tumbleweed already since a few days though.
Is your system up-to-date?
What exact version of libQt5Core5 do you have installed?

Tumbleweed is on snapshot 20160229 and libQt5Core5 is 5.5.1-4.1

Ok, that should contain the fix.

Hm, I just tried the exact steps you mentioned, and there’s no hang here. (13.2 with latest packages from KDE:Frameworks5 and KDE:Qt5, the devel repos for Factory/Tumbleweed)

Maybe it’s fixed with the next Tumbleweed update then?

Thanks for trying that :slight_smile:

Now on TW 20160301 and the “problem” still exists.

Dolphin/Ark etc has nothing to do with it. It’s the file open/save dialogue, whenever the context menu is opened in the directory/file list, that causes the hang. Context menu opens then … hang.

This affects both existing users on this machine, however, if I create a new user, that user is not afflicted with this bug.

After some further testing the cause of this is when “Application Style -> Widget Style” is set to “Qtcurve” (That being the style both existing users had set.) Now I know this previously worked, so I’m guessing that something in the last (KDE) frameworks update has caused some incompatibility with Qtcurve. Changing widget style to “Oxygen” or “Breeze” eliminates the bug.

Where would it be best to report the bug in this case? Qtcurve or the file open/save “thing” (is that kio… one day I’ll learn :\ )

Ok, that explains why I couldn’t reproduce the problem.

Hm, I still cannot reproduce it after switching to qtcurve though.
Neither with qtcurve-qt5-1.8.18-4.1.4 that’s included in openSUSE 13.2, nor with 1.8.19~git20150303-22.2 from KDE:Extra.

Maybe it’s some specific setting?
I only tried qtcurve’s defaults.

Where would it be best to report the bug in this case? Qtcurve or the file open/save “thing”

Qtcurve I’d say, considering that the problem only occurs with that style.

(is that kio… one day I’ll learn :\ )

Yes, the file open/save dialog is provided by KIO.

I have qtcurve-qt5 1.8.19~git20150303-1.5 from the TW repo, which is the same as from KDE:Extra I believe, apart from the build number.

Maybe it’s some specific setting?
I only tried qtcurve’s defaults.

Yes… and I think I know which one(s), but I’ve not changed them yet to prove it. If I use the default qtcurve style I don’t get the problem.

If you want to play around… try this style (the offending one):

http://paste.opensuse.org/view/raw/6d8881c5

I need to try a few things first, then depending upon the outcome, perhaps file a bug against qtcurve…

As always… Thanks :wink:

Yeah… right… we all know what thought, thought :stuck_out_tongue:

This is going to take a while to find the offending setting, or combination of settings. I may just tweak the default style a little to my liking and leave it at that.

Well, I randomly removed the last 14 lines, and that fixed it. :wink:

So it must be one of those:

titlebarAlignment=centertitlebarAppearance=customgradient3
titlebarButtonAppearance=agua
titlebarButtonColors=#FF0000,#FFFF00,#00FF00,#0066FF,#C000C0,#FF8000,#D6D5D1,#00C0C0,#D6D5D1,#FF7F7F,#FFFF7F,#7FFF7F,#7FB2FF,#C078C0,#FFBF7F,#303030,#5FC0C0,#303030,#C3C3C3,#C3C3C3,#C3C3C3,#C3C3C3,#C3C3C3,#C3C3C3,#C3C3C3,#C3C3C3,#C3C3C3
titlebarButtons=11285
titlebarEffect=etch
titlebarIcon=none
toolbarAppearance=soft
toolbarBorders=dark
tooltipAppearance=soft
useQtFileDialogApps=audacity,googleearth-bin
version=1.8.18
windowBorder=32
windowDrag=2

You maybe won’t believe it, but the winner is…

version=1.8.18

Remove that line with the version number, and your original config should not cause hangs any more.

Which was the version of qtcurve I was using when I created that style…

Remove that line with the version number, and your original config should not cause hangs any more.

Indeed, it does now work without hanging…

Random ? Hey ? 14 lines out of 174 … and you just got lucky … Do you have the same luck with lottery tickets ? :wink:

Unrelated to the hang, but just noticed when I was playing around with the context menu.

“Create New -> Link to Device” has gone absent without leave…

http://paste.opensuse.org/view/raw/6bbfa233

I thought (hmm, thought again); I thought I’d seen a bug report about that but don’t seem to be able to find it now…

Yeah, I actually wanted to do a binary search.
But I didn’t bother to put the cursor to the exact middle of the file, I just randomly clicked somewhere and deleted to the end of the file.
And then it worked already after the first try.

Do you have the same luck with lottery tickets ? :wink:

Unfortunately not… :cry:

“Create New -> Link to Device” has gone absent without leave…

This is no bug really.
Those entries are only available in kde-baseapps5 (kdebase4 previously in openSUSE) which has not been released yet. Although I actually think they got removed there too meanwhile because they are not really needed nowadays.
Why would you want to create a link to a hard disk (or floppy drive, or whatever) this way if it is displayed in the file manager and the device notifier anyway?

If you want the “Link to Device” options, copy over the KDE4 entries from /usr/share/kde4/templates/ to /usr/share/templates/. You need the libXXX.desktop file and the corresponding .source/XXX.desktop one.

You can maybe call it a bug though that the sub menu is shown even though no templates are installed.

No, I don’t specifically want them. Had it not been for the problem with the top level context menu I doubt I would even have noticed they were missing.

Thanks… :slight_smile: