What simple simple GPS software is there for 11.1?

Is there any GPS software available that will allow communication with my Garmin Etrex that works in a window as opposed to through the command line?

See if this link helps you out any

Many thanks for that link it looks as if it may be very useful.

I use Garmin Mapsource with crossover for my nuvi, it should work with

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 2 days 23:33, 3 users, load average: 2.45, 1.83, 1.60
GPU GeForce 8600 GTS Silent - Driver Version: 185.18.14

I installed GPSMAN and it looked as if it could be a perfect solution as everything works in a window however I have been totally unable to access the Garmin Etrex I get an error message “Can not open serial port /dev/ttySO” have tried S1,and S2 but none of the options work,am currently using a serial cable connected to COM2 on the computer having had exactly the same problem using a USB cable. Unit works perfectly in ‘Windows’ with either cable.
Also tried using QLandKarte with exactly the same results.
PLEASE can any one suggest a solution.
If I have to configure something in Yast then I have no problem provided I am told what to do but if you talk about command line I am hopeless - this old dog cannot learn new tricks!!