What resets /var/log/messages permissions?

The problem is that I have a USB thumb drive that I use, but it seems that when I boot the system (or insert it on a running system), it can wind up being attached in a different place - anywhere from sdb to sdf - so I have to look at /var/log/message to find out where so I can mount it.

The problem is that /var/log/messages is read-only to root, and though I’ve reset the permissions numerous times, each time the system is rebooted, the permissions get reset. What does this, and how do I stop it from happening?

Thanks,
James

Probably the permission settings in syslog-ng.conf.

Wouldn’t it be better to fix the problem? You can mount by disk id or by label instead of by device. Not sure where this is edited, probably some hal config file. Maybe somebody who has done this can tell you.

Hi
If your using it on a windows machine label it, then it will appear
under /media/<label_name> else use the mlabel linux command if it’s
fat32.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.18-0.2-default
up 0:39, 1 user, load average: 0.00, 0.07, 0.71
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

‘udev’ is in charge of assigning something like this I believe. Check
in /etc/udev/rules.d for some examples. This should let you create
something that has a constant device name when plugged in.

Also, /var/log/messages shouldn’t be readable by just anybody. I
believe logrotate is defining the new file and permissions… see
/etc/logrotate.d/syslog for the definition.

Good luck.

ken yap wrote:
> Probably the permission settings in syslog-ng.conf.
>
> Wouldn’t it be better to fix the problem? You can mount by disk id or
> by label instead of by device. Not sure where this is edited, probably
> some hal config file. Maybe somebody who has done this can tell you.
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFJGZgO3s42bA80+9kRAvcUAKCBiZyaWAhiylhURwfpMqPWAydvGACePOUs
jdz1JUytjd36G/+VIR76jbk=
=VKCN
-----END PGP SIGNATURE-----

No doubt it would :slight_smile: The problem is that I have not been able to find any other way to fix it. Putting a label on that one thumb drive might fix it for that particular drive, but I have several things - other thumb drives, cameras, media players, &c - that mount like drives. The only way I’ve found to discover where & how they’re attached is to look at /var/log/messages.

Hi
If they mount like drives you can label them, but if not labeled they
should turn up in /media as a disk.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.18-0.2-default
up 3:07, 1 user, load average: 0.14, 0.18, 0.21
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

Some cameras don’t mount as disks by the way. PTP is implemented by lots of cameras now and is in many ways superior to USB storage as a way of communicating with the camera.