What NVIDIA Graphics Card Driver do I select?


Problem: I recently installed 11.3 on my PC and I land into these problems

  1. Resolution: Each time I log in I have to manually go and set my resolution to 1024*768.

  2. Desktop Effects: Also I cannot see the desktop effects on my PC. When I go and activate my desktop effects, I get this error:

"Failed to activate desktop effects using the given configuration options. Settings will be reverted to their previous values.

Check your X configuration. You may also consider changing advanced options, especially changing the compositing type."

How do I overcome these problems?

Here are my system specs:

CPU Information:

Processor (CPU): AMD Sempron™ 140 Processor
Speed: 2,712.01 MHz

Memory Information:

Total memory (RAM): 741.4 MiB
Free memory: 8.2 MiB (+ 341.4 MiB Caches)
Free swap: 1.2 GiB

OS Information:

OS: Linux 2.6.34-12-desktop i686
Current user: nachiket@dhcppc1
System: openSUSE 11.3 (i586)
KDE: 4.4.4 (KDE 4.4.4) “release 2”

Display Info:

Vendor: nVidia Corporation
Model: GeForce 7025 / nForce 630a
2D driver: nouveau

Steps I tried:

  1. After reading through the SDB:NVIDIA drivers - openSUSE, I tried installing Nvidia through 1 click install. Now I see Configure Nvidia X server settings in my Recently Installed applications but when I click on it, I again get this window:

“You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server.”

M i supposed to do this to get my nvidia driver working? If so how do I restart my X server?

Any help is truly appreciated.

Thank You – Nachiket.

Hello Nihilanth, here is my standard advice for anyone using an nVidia graphics card.

You should look at this document before proceeding on…

SDB:Configuring graphics cards - openSUSE

Then, take a look at the procedure I use to install the nVidia driver as I install openSUSE 11.3:

  1. During the install, when you have the option to change your booting setup, I add nomodeset to the kernel load command for the normal load/start of openSUSE. This kernel startup option is already present for the Failsafe selection for openSUSE.
  2. During the first start of openSUSE, I download the latest nVidia Video driver to the downloads folder.
  3. I change/save the System/Kernel option NO_KMS_IN_INITRD from “No” to “Yes” in the /etc/sysconfig Editor in Yast.
  4. I do an update of openSUSE on the first run of openSUSE and then a restart/reboot.
  5. In grub OS selection I add the command line option “3” to the openSUSE start line so that I just go to the run level three terminal prompt.
  6. I login in as root and change to the /home/user/Downloads folder.
  7. I run/install the NVIDIA video driver using “sh ./NVIDIA-Linux-x86_64-260.19.21.run” and answer all questions as appropriate for my system.
  8. Type in reboot at terminal prompt to restart the system with new video driver.

Now when you say you used the one-click install, what does that mean you installed? Did this add the **nomodeset **command to your kernel load options for openSUSE? Did this add the two kernel files that include the nVidia graphics driver in YaST / Software Management? You can open Software Manaement, search on nvidia and see if anything got loaded. If so, perhaps you don’t need to load the driver the hard way. If you open YaST / Software Repositories, did the nVidia repository get added for you? Finally, you can look at your grub menu.lst file and see if the nomosdeset command was added using this terminal command.

sudo cat /boot/grub/menu.lst

There is more than one way to install the nVidia video driver. The nouveau driver, if being used, indicates you have not installed the proprietary nVidia video driver. You need to be careful in that you only need to install it one way, not all different ways.

Thank You,

Check out post number 3 here:
Nvidia for Newbies part 1

Hi jdmcdaniel3 and Sagemta,

 Thank you guys. Your advice really helped. Now I have both nvidia drivers installed and my screen resolution by default is set to 1024*768. :)
 I had to do one thing manually though. And that is to set the fonts. The fonts after change to the resolution to 1024*768 was very small and not legible.

 Thanks again--Nachiket. :)