what is this called?

In KDE if i push Alt-F2 i get a drop down dialog that lets me run a program by typing it in, this dialog drops down from the top of the screen.
Well, mine stopped working, there is a brief flash, not long enough to see anything at all, just a hint of a flash really but that’s it.
I’m not making any progress fixing it because I don’t know what its called.
Any help to fix this would be very much appreciated as I really depend on it to make my ‘after a reboot’ life easier.

When I do Alt-F2, I get that small window at the top. It has a “wrench”, what is typical a symbol of “configuration” at the left. When I hover over it, it says: Configure KRunner.

My conclusion: it is called KRunner :wink:

Thanks! Now if i can just figure out why it doesn’t work…

Suggested trouble shooting plan:

  1. Start the KDE System Settings and check the Shortcuts – KRunner should appear in the list of Global Shortcuts – check the Global and Global alternative settings …
  2. Hit the KDE “Start” key – the key with the “Windows” symbol – unless, you have a Linux keyboard in which case, it’s usually the key with a Penguin on it – type “krunner” and hit return – the KRunner settings should appear.
  3. Log out – from a VT (tty1 … tty6) login and empty the user’s cache directory – “~/.cache/” – log off from the VT session and login to a KDE session.
  4. Check the user’s “~/.config/” directory –

As a last resort, while not logged in to a KDE session, from a VT, delete “~/.config/krunnerrc” and possibly “~/.config/kcmshell5rc” – you’ll need to reenable some of the usere’s KDE settings if you do this …

When i hit Alt f2 the focus moves away from whatever has the focus. Could it be that the dialog is actually there but invisible?
Removing .cache didn’t help (I renamed it .cache.old), I haven’t tried removing krunnerrc and kcmshell5 yet but i am about to

Possibly, KRunner is crashing – check “~/.local/share/sddm/xorg-session.log” and “coredumpctl list” for possible crashes.

  • Running “journalctl --this-boot” from a user prompt will display the systemd Journal entries for the user – possibly also a source of information related to KRunner’s behaviour …
  • Call the KDE System Monitor – ksysguard – and search in the “Process Table” tab for “krunner” – the parent process should be “kdeinit5” …

So, I removed krunnerrc and kcmshell5 and it made no difference. krunner will execute from the start button if i type it in there but the behavior of the dialog that normally drops down from the top of the screen remains the same. The focus moves off of whatever its on and that’s it. If i clear my desktop and try Alt F2 nothing obvious happens - but wait! I now notice a couple of white pixels appear about where the drop down should be coming from. Maybe the dialog is resized into a couple of pixels, or shoved off above the visible top of screen. In any case, i cant grab it to resize it or drag it, and clicking the pixels makes them go away.

What happens if, you simply execute “krunner” from a Konsole window prompt?


Are you absolutely certain that, all patches have been correctly installed and, that especially the Qt libraries have been correctly patched?

  • “zypper verify”
  • “rpm --verify --all”
  • “rpmconfigcheck”

**FIXED IT! **lol!

So, somehow milou5 got uninstalled. I found out that was the case by using journalctl --this-boot ( but as root) as you recommenced and then hit Alt F2 while i was watching journalctl output and it spit out that
Thanks for all the help!