What is the startup process

Hello All

I have a strange hardware problem that is fixed by restarting the driver. I have tried to fix the problem directly, but am stuck and not getting much help on the forums. So I am resigning to a work-around solution. I want to add a script to the startup sequence that simply restarts the driver. It is important that the script has root privileges. 

I tried to add a script `restartDriver' to init.d with a link in rc5.d called `S20restartDriver' yet, it doesn't ever seem to be called. In `restartDriver' I have several echo calls that print to the stdout and a file to tell me that it worked. Yet, I never see anything that it was executed when I restart. I have added things to init.d successfully before in Suse 10.1 however, having trouble with Suse 11.1.

I don't care if this script is ran in the init.d stage or other stages. It isn't a service, just a little fix that needs to be run at the latter part of the start-up procedure. Are there other scripts that I can edit? I am not very familiar with the start up procedure, and have been trying to find documentation for KDE and Suse. Yet, no success. Any help would be greatly appreciated. 

Take Care

Computer Info:

Motherboard: Asus M3N78-VM
CPU: AMD Phenom™ II X4 940 Processor
Total memory (RAM): 3.7 GB
Kernel Version: x86_64
Operating System: openSuse 11.1

You could always put the whole script into /etc/init.d/boot.local :)??

Hi BenderBendingRodriguez

Thanks for the help. I did as you instructed, the work-around commands were executed, yet it wasn't late enough in the boot process to have an effect. 

I should elaborate, the problem is with my sound card. From init.d sound is initialized when switching to runlevels 2, 3 and 5. The driver needs to be restarted after that point for it to fix the problem. Are there any other scripts executed after all the run level scripts are executed?


PS If you know who are the people that manage the start-up/sound for openSuse please tell me. I would like to talk to them directly, so hopefully this problem is resolved in future releases.

Check when is the alsasound initiated and change that to as early as possible (preferably just before the boot.local script).

But what is the problem with the sound you’re having??
Have You tried this tutorial?
SDB:AudioTroubleshooting - openSUSE

Init scripts on SUSE must have the metadata for the service in the significant comments at the top of the file. See /etc/init.d/skeleton for an example and documentation. Then they have to be registered with the init system with insserv or chkconfig. Otherwise the symlinks are not created properly and the scripts are not sequenced to execute.

If it’s a patch for alsasound, maybe you could modify the existing script to run the initialisation twice, or do you need to wait a while before the second run?

Hello All

 BenderBendingRodriguez in Yast I tried switching alsasound to start at the B run level, then have it restarted in boot.local. That had no effect. 

 I have gone through the recommended tutorial (and several others). The problem is not that I don't have sound, it is just that the driver doesn't share the sound channels. Thanks to the tutorial, I am starting to suspect that pulseaudio is the problem. I would like to know when in the startup sequence pulse audio is started.

 For more details on the specific sound problem see my post: [Applications cannot share sound channels - LinuxQuestions.org](http://www.linuxquestions.org/questions/linux-hardware-18/applications-cannot-share-sound-channels-732943/)

 ken_yap thanks for the info on the meta data and the other programs. I manually added the symbolic links, I guess more is needed in Suse. Good to know for next time. 

 ken_yap I added the following to my alsasound script to see if it works. Let me reboot and I will report further.

Thanks for all the Help
Take Care

	if  "$PREVLEVEL" = "N" ]; then
	    test -d /proc/asound && start_rest
	    stop_all  # Added to fix problem
	    start_all # Added to fix problem

Hi ken_yap

Thanks for your help. I tried your suggestion, even added a sleep 60s before the restart. Still nothing happened. I am starting the think that the problem is with pulseaudio. So teh restart would have to happen then. 

Could anyone tell me when pulse audio starts. Also could someone tell me how to disable its start up. Thanks.

Take Care

> Could anyone tell me when pulse audio starts.

no idea

> Also could someone tell me how to disable its start up. Thanks.

if you search these fora you will (eventually) find that some folks
SOLVE all their sound problems by simply removing all pulse audio
(using YaST)…

please do your own research before you TRY this! (that is, if you
remove pulse audio and your machine catches on fire and burns down
your house–do NOT come crying to me!)


First thing i do is to remove PulseAudio :slight_smile: openSUSE’s kernel doesn’t allow it to be normal instead it’s always choppy.
Alsa all the way.

P.S. You give useful info but it looks like there is no one that could help You with that, it’s too complicated.

I one of those who completely removed pulseaudio. On my laptop that is. If I were you, and not running Gnome, I would do so as well. It might even be, that if you reboot and reinstall pulseaudio it loads later than originally and does not interfere anymore. Read something like that on Ubuntu fora.
Point is, that you’re creating a non standard situation. Doing so requires detailed information to be saved. I know from experience that it’s always these things that start counting when there’s other problems and you don’t remember why you changed what.

By the by, the best guy who can help you with sound related problems is oldcpu
(If he is not responding to this post, may be because it’s title doesn’t say that it is a sound-related post, contact him directly with a reference to this post so that he may respond).

Hello All

I have been away from the forum. As we all know the work that pays the bill always needs attention. I just wanted to thank you all for the help. I am happy I know my problems. All the advice given was very helpful. 

This thread has gone way off topic, I think it needs to be closed. I have opened a new thread on removing pulse audio. If you are curious about my progress, please go to:

How to safely remove/disable pulse audio? - openSUSE Forums

Thanks again

Hello All

Well first off I just wanted to thank everyone who offered help. I finally have fixed my problem. I posted to several threads, so I have summarized them below with links. So if you are having similar problems you can read about my experience below. I have tried to give detailed accounts. So hopefully there is enough information that you can fix it a lot easier than it was for me. 

Take Care

Original Post when I first noticed the problem:
Sound routed to wrong audio channel - openSUSE Forums

An attempt at using a work-around solution:
What is the startup process - openSUSE Forums

Armed with new information I made several posts about the debugging process:
Applications cannot share sound channels - LinuxQuestions.org

Once the problem was identified I used this thread to discuss what I did to resolve the problem:
How to safely remove/disable pulse audio? - openSUSE Forums