What is the difference between PCM and Front in kmix?

I have no idea what PCM is, can someone please explain?

I have 2 sliders in kmix, one PCM, the other is called “Front”.

I mapped my laptop volume controls to the “Front” one, and it seems to work (although NO on screen feedback!), but was wondering if I should map them to “PCM” instead.

Thanks :slight_smile:

  • wehrmacht,

different channels: PCM (pulse code modulation) cares about the internal signal, means you are changing the volume “before” it leaves the soundcard. “Front” and others are the output channels.
I wonder why your output is named “Front”: That’s normally the output jack where you put in your head set. Do you see “Master”?
Anyway, it doesn’t really matter which one you use, as long as you don’t record things.


I have a Dell Inspiron 1501 with only a Front and PCM option in KMix, on first boot PCM was what was set as the main channel. All that I did was right click the KMix icon in the system tray, click select master channel, and set it to front.

After doing that, I set the volume keys to the corresponding shortcuts, and everything worked great. Of course, it seems to forget these shortcuts on reboot…

Anyway, I’ve always preffered front as the master channel. I usually don’t keep PCM at full volume though, as I find the sound quality can be better that way.

Lysdestic those are rather limited options, … it has my curiousity perked. … Would you mind running the following from an xterm/terminal/konsole (as a regular user) with your PC on the internet (copy and paste it into the xterm/terminal/konsole). It will automatically download and run an audio diagnostic script, creating a URL with a summary of your PC’s audio configuration. And then paste that URL here?

wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && bash alsa-info.sh 

I would hate to feel as if I am hijacking a thread, but as it is on topic I will happily post the URL for you.

Here it is.

Thanks, … I’m surprised you don’t have more options in your kmix. Looking at the script I do see it limited to:

Simple mixer control ‘Master’,0

Simple mixer control ‘PCM’,0

Simple mixer control ‘Capture’,0

Simple mixer control ‘Capture Mux’,0

Simple mixer control ‘Digital’,0

Simple mixer control ‘Input Source’,0

… and I note the laptop has an HDA ATI SB and your audio hardware codec is recognized as a “Conexant ID 2bfa” but the “2bfa” is not decoded. It makes me think alsa driver support is still lacking a bit for this laptop.

Yeah, I knew of the other channels, it just appeared as if they were all capture type channels.

As nice as it would be to have full use of the card, it isn’t that important. It makes noise, and laptop sounds are never amazing anyway. Who knows, maybe a future alsa updare will remedy the situation.


I ran your script out of curiosity and it uploaded stuff to pastebin!

Sorry if I messed anything up oldcpu :S.

Thanks for the clarification.

I also lose my key assignments on reboot! Not a very good situation with laptop keys in this release :(.

I think I’m going to hit bugzilla because it seems silly to not have something we had in previous releases.

Oh yes, here is the pastebin URL if it is of interest to anyone: general pastebin - kev - post number 1056255

I found from another thread that if you use keytouch you will have better luck. It works better, and keeps the settings after reboot. Solves my issues with the reboot. :slight_smile:

Thanks, I was looking at that. It notes you have an option in your /etc/modprobe.d/sound file of: model=laptop and that you have a CX20549. The 20549 used to be called the 5045 and 5047. When I look at the model options for the 5045 I see this (which does not have a “laptop” option):

948		Conexant 5045
949		  laptop-hpsense    Laptop with HP sense (old model laptop)
950		  laptop-micsense   Laptop with Mic sense (old model fujitsu)
951		  laptop-hpmicsense Laptop with HP and Mic senses
952		  benq		Benq R55E
953		  test		for testing/debugging purpose, almost all controls
954				can be adjusted.  Appearing only when compiled with

but the 5047 has these options (which include model=laptop):

957		Conexant 5047
958		  laptop	Basic Laptop config 
959		  laptop-hp	Laptop config for some HP models (subdevice 30A5)
960		  laptop-eapd	Laptop config with EAPD support
961		  test		for testing/debugging purpose, almost all controls
962				can be adjusted.  Appearing only when compiled with

Linux Kernel Documentation :: sound : alsa : ALSA-Configuration.txt

If you are curious, you could in your /etc/modprobe.d/sound file, try changing “laptop” to “laptop-hpsense” and restart your alsa (from an xterm/konsole with root permissions) via “rcalsasound restart” and then check out your mixer. If that doesn’t improve your options, then instead try “laptop-micsense” (with same “rcalsasound restart” … ) and also laptop-hpmicsense, laptop-hp, laptop-eapd.

And of course, you can simply leave it (or put it back to) model=laptop

I actually put that line in there myself (model=laptop), I learned that a while back for getting the speakers to mute when plugging headphones in :D.

I’ll give your better suggestions a go though and report back.

Thanks :).

Actually the biggest problem I’m having at the moment is the mixer forgetting the (laptop) keys that I assign to it on each reboot, extremely annoying!

I get no on-screen feedback either like I did under 10.3, well, the little red mute icon comes on when I press mute, but no volume feedback :(.

But I guess that’s a SUSE problem, not an ALSA problem.

I do not think saving your key definition is an alsa function. Typically save alsa settings, one will type with root permissions:
alsactl store

But as noted, I do not believe this is an alsa function for your case.

Actually the biggest problem I’m having at the moment is the mixer forgetting the (laptop) keys that I assign to it on each reboot, extremely annoying!

I get no on-screen feedback either like I did under 10.3, well, the little red mute icon comes on when I press mute, but no volume feedback .

I was having a problem with my volume up\down\mute keys being forgotten on reboot when I was setting them with KMix, after I used keytouch to set them, they saved - and it gives on screen notification when they arre used.

I tried keytouch, but it didn’t work :(.

Well, it worked to some extent, but not with kmix. I downloaded, compiled and installed the kmix plugin but still no go.

Maybe because I’m using kde4-1 beta. I also have a problem with my arrow keys in terminal, very annoying!

Oh well, thanks for the help anyway :).

You should even have to configure the shortcuts in kmix - it bypasses that with the volume control, at least from the way I have it figured out.

I didn’t need to install a KMix plugin either. This is on KDE 4 beta for me as well.

I basically figured out keytouch myself, so I could be doing something odd, but it worked for me.

Open up keytouch, find a laptop similar to yours. I found that just about all of the Dell Inspiron laptops worked for me, despite the different keycodes. Doing that should do the trick, or it did for me at least. Experiment, play around with it - or maybe someone else here has better solutions for using keytouch.