What is the best way to access computer in local network?

The desktop computer stores most of our family’s files and is mostly powered on, installed with Debian/openSUSE (KDE4).

We have 2 more portable (also Linux, KDE4) computers and frequently need to access files stored in the desktop. Currently file transferred is by usb thumbdrive which is troublesome.

The computers are all connected to a wireless router that provides access to the internet.

Reading/goolging and understand that there are many ways to share files to the extend that I am lost - Samba, NFS, SSH …

My problem is to find out:
What is the best way to access computers within the local network? “Best” here means:

  • Secure
  • Relative ease to setup
  • Easy to use, file access with GUI (file manager?) as the entire family is using the computers.

Thanks in advance for the advise.

Since your computers are all running Linux, I would go for the native NFS option.

Some useful tutorials:

Debian Linux file and print server: NFS, CUPS, LPR-Geek-Free Debian Tutorials and Stuff

OpenSUSE NFS Configuration Tutorial | Tejus’s Blog

Hello michalng,

I always use KDE’s fish protocol for file transfer.
This protocol uses ssh for the connection.
To use it open Konqueror or Dolphin and enter this in the address-bar:


So if you have a computer at with a user named linux you can use this command:


You can even open in a specific directory with this:


Good luck!:wink:

For an “on/off” usage, I would go for “fish” as well. It’s easy, fast and reliable. NFS is as well, but is a bit more static in it’s defaults.

Another equally easy means similar to ‘fish’ is ‘sftp’. Using the above example:


So if you have a computer at with a user named linux you can use this command:


You can even open in a specific directory with this:


Note one needs to either enable open port#22 in their firewall or select the “Secure Shell Server” as an allowed service. ie YaST > Security and Users > Firewall > Allowed Services and add Secure Shell Server.

Also, dependent on one’s openSUSE version it is possible that the ssh daemon is not started by default. So to ensure it is started by default go to YaST > System > System Service (run level) > Simple Mode > and scroll down to sshd and ensure YES is selected for the “ssh daemon”.

Note if one has their home router setup properly it is even possible to access one’s home PC from a laptop, using ssh/sftp.



Tried the “easiest” fish using Konqueror and Dolphin from

  • openSUSE 11.2 (KDE4) to Debian Squeeze (KDE4)
  • Debian Squeeze (KDE4)to openSUSE 11.2 (KDE4)

Both time get me an error http://img52.imageshack.us/img52/1989/fishq.jpg

I must have missed something :frowning:

You did configure and start sshd on the target machine(s)?

Hello michalng,

Did you opened port 22 in your firewall?
Do to this go to YaST->Secuirity and Users->Firewall.
At your left click on “Allowed Services”.
Now select “External Zone” in the combo-box “Allowed Services for Selected Zone”.
Select “Secure Shell Server” in the combo-box “Service to allow” and click on add.
Now try it again.

Good luck!:wink:

I am trying to access the files in the desktop. Am I right to say that ONLY the desktop needs the openssh package (which includes both the client and server) installed?

Or do I have to have ssh installed on both computers?

This here sounds quite different:

  • openSUSE 11.2 (KDE4) to Debian Squeeze (KDE4)
  • Debian Squeeze (KDE4)to openSUSE 11.2 (KDE4)

You will need the server configured, accessible and running on every machine you want to connect to.

And if you configure ssh, do it in a safe way right from the beginning.

sshd pubkey authentication - Google Search

**oldcpu , Edward_Iii , **
thanks for the tip on the openSUSE firewall. My kids are using the other laptops with openSUSE. Will try it later, thanks.

hope I did not confuse anyone here, the final intent is to access the files on the desktop from the other laptops.
As I am now trying to get the connection working, so I am desperate enough to connect anything to anything.

Back to actual intent of accessing files in desktop from laptops,

  • is it true that ALL desktop and laptop must have ssh installed
    or is ssh only required on the desktop?

  • besides the yast firewall config as suggested, are there other configuration that is needed for fish to work?

  • or worst, are there other configuration that is need it to address security issues as Akoellh had suggest?

Hello michalng,

No thanks.

As far as I know you need to install ssh on each computer.

You could change the default ssh port to another.
Note that if you do that you need to open that port in the firewall and close the previous one.
And you could disable ssh root login (PermitRootLogin in /etc/ssh/sshd_config).

Good luck!:wink:

I know you mentioned the kids were using the other laptop with openSUSE, but assuming the other laptop is a dual boot for openSUSE/winXP and if the kids are running winXP on the other laptop, then if the winXP laptop firewall is appropriately setup, you can access its hard drive from openSUSE with konqueror by typing in the location bar something like:




ie to use the examples above, but instead of Linux to Linux we are referring to Linux to Windows PC:


So if you have a computer at with a user named winuser you can use this command:


or sometimes just access the windows PC in general (I think)


Typically when the above does not work it is because the winXP firewall has blocked the connection attempt.

Thanks all for the help.

FISH works!

SSH is already installed in my openeSUSE KDE4 default installation so there is not addition installation required. However, as oldcpu and Edward_Iii had mentioned, the firewall need to allow the service before fish works.

Hello oldcpu,
the kids are using openSUSE :wink:

you mentioned :


am I right to say that samba have to be installed and configured on all the desktop and laptop before this will work?

Yes but again it probably is already installed because samba is used to network with Windows. Pretty much the sane dance as with fish the correct ports need to be open and samba must be started. There is a samba set up in Yast