What is the "best" format for a USB HD?

Seems this is a common problem…

Having been given a deal on a LaCie 500 GB USB HD I purchased even though it isn’t listed in the HCL.

As expected it has NTFS-related issues.

My Archos mediaplayer is formatted as vfat, and that seems to work perfectly on my 11.1*, Windows and OSX.

My question is, before formatting my drive as vfat, does anybody recommend a different file system, and why?

Secondly, the only way that I think I can do this is to plug it into a PC running Windows since KParted won’t let me modify it in this way. Is there an alternative program/method that will allow me to reformat in OpenSUSE 11.1?

Thanks in advance.

*(although oddly files that are put into, for example, “Video” folder are not accessible through the corresponding icon, and have to be accessed through the ‘data’ icon. I can live with this but would be very interested if anybody has any experience of Archos (405) and can offer an explanation or suggestion of how to stop this from happening!)

FAT has a 4GB file size limitation so if you need more than that, choose NTFS (if you’re going to use it on multiple OSes) as it’s supported and can be read/written on all platforms, Linux, Mac, Windows (I think UNIX too? not sure though)

If you’re going to use it exclusively on Linux, then choose Ext3 or XFS. There are drivers for these FSes for Windows but I’ve no clue how good they are. No idea if there are any for OS X

For formatting, use YaST disk partitioner or gparted

You seem to have low expectations, I would fix the issues (or be at least a lot more precise on them).

For sure vfat is not a good choice for big files, but partitioning such a big drive -perhaps with different filesystems- would be.

Secondly, the only way that I think I can do this is to plug it into a PC running Windows since KParted won’t let me modify it in this way

I had never any issues with partitioning drives, no matter what FS was on them, so this is most certainly a user’s error.


There are a lot more tools for that job, the CLI-based tools ALWAYS worked for me.

Thx for your replies. I will hunt around for the CLI tools; lack of confidence means it’s not my first choice.

I didn’t have low expectations at the time I bought the disk! I was trying to show that having stumbled, I have bothered to read around the issue and it is not unknown. In particular External Hard Drives–How to locate and mount - openSUSE Forums

microchip8, from your reply, you appear to be suggesting that NTFS is a viable format? If this is the case can you tell me why I cannot R/W to the disk, or even see it in Dolphin?

The partitioning tool in YaST gives a popup saying that it cannot be used to modify the disk in question.

I would dearly like to do it with the CLI but it is still a bit of an unknown for me. When using it, there seems to be less opportunities to play around and try stuff out. Intuition isn’t rewarded in the same way it is with a well-developed GUI, but expertise is.

My worry is that I will somehow render the disk unusable and won’t be able to take it back for a refund.

I will search around CLI formatting commands, though would massively appreciate a bona fide suggestion before actually running it.

You need the ntfs-3g driver NTFS - openSUSE
Yes, NTFS is a viable format for multiple-OS compatibility

The partitioning tool in YaST gives a popup saying that it cannot be used to modify the disk in question.

This has happened to me in the past too, esp on NTFS file systems. I always “fix” it with gparted

Thanks again microchip8. I did read that earlier, and understood that from 11.0 onwards it was pre-installed, so not an issue?

This might sound really dumb, but can I use gparted if I have KDE? I’m guessing not…

Th advice in the last para. of the linked article, relating to hotplugging of ext. HDs, contains a NOTE stating that KDE 4 is not affected (I have 4.1.3). Is it worth following the advice there?

My thought is that since filesize >4 GB is not a concern I should format it as FAT, which I will have to do using the CL. It will then be hotpluggable and will also function on my office machine which runs Windows? Is this correct?


Note it is important for the Linux ntfs-3g driver, that any external USB drive formatted as NTFS is unmounted/removed properly when using both Windows and Linux.

Hence there can be cases here the NTFS formatted external USB drive is “dirty” having NOT been removed properly from MS-Windows. The solution in such a case is to reboot to Windoze, plug in the drive, then remove it properly from Windows by first unmounting it using the icons (as appropriate) in the lower right corner of the Windoze operating system. Then physically remove the drive when told it is safe to do so. In some cases, this is not enough, and one has to run "fsck <drive : > " from a DOS/Command window under Windoze to clean the drive. fsck - Wikipedia, the free encyclopedia

Note Linux may NOT mount the drive if it was made dirty by Windoze and it may not provide read/write permissions to the drive if it is “dirty”.

Also, recent openSUSE versions hotplug automount the drive, so it is often best not to put entries in /etc/fstab for the external drive, as that can cause mounting confusion/problems.

yes you can use gparted under kde, or grab the live CD and burn it to disc, then boot from it like I do (since I use it on many systems)

That’s something to bear in mind for the future since I will deifnitely be swapping between the two OSs, but cannot apply in this case since I just took it out of the box (at least I assume it cannot apply).

Can someone suggest a foolproof way to partition/format from the shell?

Otherwise, use gparted which if understand correctly I can only use if I’m running the liveCD or have gnome?

Does anyone have experience with PartedMagic? Any good?


there is parted, which the yast partitioner also uses. it’s a command line partitioning utility

no, you can use gparted if you install some of its gnome dependencies (if it has any). you don’t really need to get the livecd version, I just pointed out to it since I use it across different systems

Typically external hard drives come preformated with either VFAT or NTFS. NTFS is most common.

My new USB external fantec (500GB) drive was pre-formatted as NTFS and it was dirty out of the box. ie the manufacturer in their quality tests probably did not shut it down properly. So before I used it in Linux the first time, i had to take it to my wife’s PC, and mount it and then unmount it properly in Windoze.

Are you SURE you want to do this? The drive should already be formatted.

oldcpu said:

Are you SURE you want to do this? The drive should already be formatted.

No. I am not at all sure. :\ But if I have understood what my computer is telling me, and correctly interpreting the experiences that others have posted, the situation is this:
NTFS disks require manual mounting and (careful) unmounting and are generally a bit of a hassle (based on the number of posts related to this subject).

So my ‘logic’ is as follows: If I reformat the disk as VFAT, it will mount automatically (as my Archos player does) and have R/W and hotplug capabilities (also on Windows).

My method for doing this (despite the red herring of using CLI tools that was introduced earlier) will be to use gparted as suggested by microchip8.

If the above sounds like a bad idea, someone please say so. Otherwise, I will go ahead and see what happens.


Then I must be constantly doing something wrong.

Or my interpretation is incorrect :wink:

Thanks microchip8, gparted seems to be working great.

Whilst the YaST partition tool said that there was an NTFS partition, this app. says HFS+ which I think is a MAC thing. Now I’m very confused.

It looks like this:

So, does creating a single VFAT partition sound like an acceptable solution?

Yes, just create a FAT one. Seems your partition table somehow got messed up if it lists it as HFS+

Thanks again microchip8. I have deleted all but the smallest partition which cannot be modified for some reason. If I use the create partition table option, I think that will wipe the entire disk and allow me to create a new, single (primary) partition in fat system. Should I go with the default msdos option?

Much appreciated.

Yes, msdos is good for default as partition scheme. If you cannot for some reason delete this particular partition, you need to wipe out its partition label/scheme and maybe even low-level format it which can be done with disk manufacturers utilities. You can get them for free from Seagate, WDC, Hitachi, etc Low level format utilities for the hard disk (they are livecd’s usually so you’ll need to boot from them)

I had in the past disks which no matter what I used on Linux and tried on, they still somehow ended up with wrong partition labels so I often use such manufacturers tools to force low-level formatting and these tools will do it without a problem, not even stopping at the problems I had with Linux partitioning tools. After low-level formatting, you can create your new partitions

microchip 8 THANK YOU! Works like a charm, can R/W and hotplugs in and out! Thanks to all those others who gave advice. BBQCH :-)))))

what? no reputation point? :stuck_out_tongue:

Glad it works :wink: