What is the best application to play dvd's?

I have all multimedia packages installed as the instructions of opensuse site (ffmpeg, libdvdcss, …) and plus some others not mentioned there (gstreamer, libav …).
Recently I was watching a dvd in kaffeine but several times the video and audio had small stops of about one or half second. It even came to the point of skipping a bit of the video. I tried vlc and the same thing happenned up to a point where the video froze at all. Also in other dvd’s, when I tried to watch the content of a menu option vlc skipped the first few second of that scene before playing it.
I tried smplayer and the exhibition of video was perfect except by the fact that it don’t recognize dvd menus and subtitles. All mplayer gui’s don’t recognize them.
So what player available for opensuse is able to recognize menus, subtitles and at the same time play dvd movies without other problems?

I have all multimedia packages installed as the instructions of opensuse site (ffmpeg, libdvdcss, …) and plus some others not mentioned there (gstreamer, libav …).
Recently I was watching a dvd in kaffeine but several times the video and audio had small stops of about one or half second. It even came to the point of skipping a bit of the video. I tried vlc and the same thing happenned up to a point where the video froze at all. Also in other dvd’s, when I tried to watch the content of a menu option vlc skipped the first few second of that scene before playing it.
I tried smplayer and the exhibition of video was perfect except by the fact that it don’t recognize dvd menus and subtitles. All mplayer gui’s don’t recognize them.
So what player available for opensuse is able to recognize menus, subtitles and at the same time play dvd movies without other problems?

First off, I use the Kaffeine/KDE3 player, which you can also obtain from Packman. It works great and plays all videos without errors. A lot has to do with:

  1. Codec Installation
  2. Video System & Driver
  3. Speed of your Computer

On item 3 though, properly setup Linux will play rings around slow Windows on older machines. I have taken single core Laptops with built-in Intel video and was able top play all video and in full screen. Now, when I find a combination that does not work with Linux for some reason I do admit to selling or otherwise pawning it off on a Windows user somewhere. So, Lets look at item 1. You say you have installed all of the multimedia as required. Prove it to yourself by downloading mmcheck, a bash script I wrote. If you can pass the mmcheck test, your multimedia should be good:

MMCHECK - Version 2.35 - Check Your Multimedia in 16 Steps - Bash Script File - Blogs - openSUSE Forums

Do not dismiss ANYTHING suggested in mmcheck. Meet its suggestions or come back with why you disagree, as you ponder your inability to play DVD’s straight through. Next, what video graphics do you have? When faced with nVIDIA or AMD/ATI, I must HIGHLY recommend you consider loading in their proprietary video driver. If you have Intel, you may be good, but even then, there are Xorg and Mesa Updates even and including a newer kernel to consider. Last, the speed of your computer. Laptops are on the bottom, along with 5 plus year old computers. There may not be much one can do, but I have to see what else you have done first because even slow computers can play DVD’s in almost every case (Please note that I did not say ALL cases). Full Computer and graphic specifications could be helpful in this final mater. Make sure you have Packman repository added in, I normally suggest using a 64 bit systems and look for that other Kaffeine/KDE3 and give it a try.

Thank You,

On Thu, 04 Aug 2011 00:36:04 +0000, fernando a martin wrote:

> So what player available for opensuse is able to recognize menus,
> subtitles and at the same time play dvd movies without other problems?

Try the packman version of xine.

Jim

Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

I tried mmcheck and everything was ok. The only things suggested on it that were missing on my system was sox, libavdevice52 and mplayerplug-in. I installed sox. I already had libavdevice 53 but installed 52 also. And mplayerplug-in does not exist in packman. It also suggested me to change java from gdk to sun which I’ll do later.
I had libdvdcss from opensuse and now I’m trying it from videolan.
Wether it’s coincidence or not kaffeine is slower than ever to play dvds. Sometimes clicking on an item on a dvd menu doesn’t even come to have any effect.
VLC remains the same.
But what is curious! I installed gxine and it plays dvd perfectly. Sorry it doesn’t respond to multimedia keys on kde and on full-screen it doesn’t display buttons. But working around it the reproduction is very fine. Well, doesn’t kaffeine works using xine engine? So how can gxine work fine and kaffeine not?

I tried mmcheck and everything was ok. The only things suggested on it that were missing on my system was sox, libavdevice52 and mplayerplug-in. I installed sox. I already had libavdevice 53 but installed 52 also. And mplayerplug-in does not exist in packman. It also suggested me to change java from gdk to sun which I’ll do later.
I had libdvdcss from opensuse and now I’m trying it from videolan.
Wether it’s coincidence or not kaffeine is slower than ever to play dvds. Sometimes clicking on an item on a dvd menu doesn’t even come to have any effect.
VLC remains the same.
But what is curious! I installed gxine and it plays dvd perfectly. Sorry it doesn’t respond to multimedia keys on kde and on full-screen it doesn’t display buttons. But working around it the reproduction is very fine. Well, doesn’t kaffeine works using xine engine? So how can gxine work fine and kaffeine not?

Gxine and Kaffeine use the xine engine. However, only Kaffeine/KDE3 version uses the same configuration. I have determined that you can setup your audio using xine, but must copy that configuration to a separate location for it to be used by what I call Kaffeine/KDE4. If you have not located and gave Kaffeine/KDE3 a try, I would do so. You get Kaffeine (KDE4) by default when you install KDE4 (no surprise), but if you have added the Packman repository, use openSUSE 11.4 and search YaST / Software / Software Management on Kaffeine, you will find the KDE3 version there. I would load and give it a try. You did not mention your video system chipset/GPU/Driver and anything about your computer hardware or CPU speed. These are also important to know. You can find much of this info inside of the My Computer display.

Thank You,

@OP: Please check that you have kaffeine installed from Packman. Many of us update KDE, performing a “Switch system packages…”. If you do this after adding the Packman repo and installing the codecs etc., your kaffeine will be the one from the KDE repos. Do a


rpm -qa | grep kaffeine

the output is the installed kaffeine, there should be “pm” in the version. If not, switch to that version using Yast.

My video card is Nvidia geforce 8400 GS with 256MB, VGA compatible, connected to PCI, and using the proprietary driver in Opensuse.
My PC is 32-bit, with pentium dual processor, 1,80 in each processor and 3GB RAM.
I have kaffeine 3 and 4 and xine all installed from packman.
Playing dvd in kaffeine3 works. The image doesn’t seem so fine in all details as it is in win apps such as powerdvd. The contrast in moving images seem blur a little. It’s very little but visible when looked at with attention. But there’s no skips, stops or hangs. (Curiosity: Can kaffeine 3 be able to respond to multimedia keys in kde 4?)
The worst problems seem to be related to kaffeine4 and vlc. (And plus what seems to be unsolved all over the internet: the fact that mplayer doesn’t recognize menus and subtitles.:()

My video card is Nvidia geforce 8400 GS with 256MB, VGA compatible, connected to PCI, and using the proprietary driver in Opensuse.
My PC is 32-bit, with pentium dual processor, 1,80 in each processor and 3GB RAM.
I have kaffeine 3 and 4 and xine all installed from packman.
Playing dvd in kaffeine3 works. The image doesn’t seem so fine in all details as it is in win apps such as powerdvd. The contrast in moving images seem blur a little. It’s very little but visible when looked at with attention. But there’s no skips, stops or hangs. (Curiosity: Can kaffeine 3 be able to respond to multimedia keys in kde 4?)
The worst problems seem to be related to kaffeine4 and vlc. (And plus what seems to be unsolved all over the internet: the fact that mplayer doesn’t recognize menus and subtitles.:()

First, the issues you notice with Kaffeine 3 as opposed to using Kaffeine 4 for video is true, but only on slower hardware. By that I mean, playing Kaffeine 3 on an Intel i7 with a nVIDIA 460 and the Kaffeine 3 video issues are gone. But, on older hardware, Kaffeine 4 does seem to do better. Why I don’t use Kaffeine 4 is I like the Ctrl-V and Ctrl-H options in Kaffeine 3 to expand the video size which were removed from Kaffeine 4. As for audio, as best as I can tell, Kaffeine 3 & 4 still use xine configurations, but the audio configuration file moved for Kaffeine 4 to a new location. Here is what I said about this issue in the past:

So I have made an interesting Discovery with regards to using Kaffeine (KDE3) version 1 and Dolby Digital 5.1. The basic problem seems that there is no way to configure the Phonon xine Backend in KDE 4. There is however, a xine-config file located at:

~/.kde4/share/apps/kaffeine/xine-config

There appears to be no GUI way to change the default xine configuration (for use with KDE 4 applications) and while you can do so manually, the options seem bewildering, at least to me.

When you run xine-ui or Kaffeine/KDE3 there is an option to adjust the xine configuration using a GUI. Any changes made here are ignored by KDE 4 applications. As luck would have it you can copy the old xine configuration over the new one. The old text file configuration is located at:

~/.xine/config

If you were to use the old Kaffeine/KDE3 to adjust your xine audio configuration and then copy this file to the KDE4 location, those changes should be used by the new version 1 Kaffeine in KDE 4. After Kaffeine/KDE3 audio settings work as you desire, open up a terminal session and make the following file copy. You must overwrite or rename the old configuration file for backup.


cp ~/.xine/config ~/.kde4/share/apps/kaffeine/xine-config

So, you can use Kaffeine/KDE3 to configure your Audio setup using xine configurations and then copy the file over for use with Kaffeine/KDE4. Let me also say that I have had better luck using a 64 bit setup and loading the very latest nVIDIA driver the hard way and I bet that even Kaffeine/KDE4 (with my known audio tricks) would work in your setup. The 32/64 bit issues have been discussed before in this forum concerning KDE4 / openSUSE 32bit/ nVIDIA video driver with several people saying that combination does not work properly. So, I would ask if there is anything keeping you from switching to 64 bit and loading the nVIDIA driver the hard way?

Thank You,

I cannot switch to 64bits because my pc is 32bits.
Recently I found out that gxine is not all that much too. It also has some slowdowns in reproduction, but they only aren’t so much to cause stops. Totem has the same problem. Everything based on xine seems to have.
And in vlc the larger the cache value the worst the stops and skips. With cache value in 100 I got no stops in audio but some slowdowns in image.
[size=7][size=4]Only mplayer based apps seem to do a nice reproduction. Is there any way to make them recognize dvd menus???[/size][/size] (That would solve the problem quickly and easily.)

I have been able to get smplayer to work with menus when using the original mplayer program (not mplayer2) as apparently, mplayer2 was not compiled with libdvdread. Neither mplayer or mplayer2 provides a GUI front end, but the original mplayer most likley would play a DVD movie with menus when ran from a terminal session using the proper commands. I suggest you try smplayer and to make sure you have not installed or use mplayer2-as-mplayer and to have the original mplayer installed. I also notice that smplayer can have an issue with some DVD’s using primitive copy protection methods ( Example: Surrogates - Bruce Willis) and smplayer can fail if you have more than one optical DVD player and you do not place the moive in the default /dev/dvd device. It appears to work properly with the DVD player that has been designated as being /dev/dvd. If you have two optical drives or you have recently replaced your optical drive, you may want to edit (or even delete) the file /etc/udev/rules.d/70-persistent-cd.rules as root. It gets recreated if it is missing on a reboot and designates the default dvd player. You can read more about it here:

Multimedia Optical Drive Naming (ie /dev/dvd & /dev/cdrom) Howto in opneSUSE

Thank You,

Kaffeine using GStreamer seems to work nice too; at least it worked in the past when i did try a DVD. It`s weird that VLC is not that good to you.

Have you tried XBMC? I haven’t tried it with an Nvidia card, but it works decently on ATI cards.

I had never heard about xbmc. I got enthusiastic when I saw its professional look but I almost got mad at it. But to play dvd I had to browse through all dvd’s files as if I were in dolphin and click at them to find what one was the menu. After that the reproduction of video was terribly slow. I repeat every frame about 7 times and audio kept repeating too.
It’s weird that players such as kaffeine and vlc don’t work right. But my pc is not all that out-of-date. You may see its description on this thread.
And what is more strange is that on my first install of opensuse 11.4 that was a gnome install, where I later added kde, kaffeine worked right to play dvd, it was only slow to start the video after clicking on a menu item. And vlc was almost the same way.
After a while I felt that I no longer used gnome so to save space and keep system clean I made a fresh kde install. From that on I began to have issues with dvd’s.
Does anyone know what difference there may be between a gnome install with kde added later and a fresh kde install so that I started to have the problems above with the second one?

I had never heard about xbmc. I got enthusiastic when I saw its professional look but I almost got mad at it. But to play dvd I had to browse through all dvd’s files as if I were in dolphin and click at them to find what one was the menu. After that the reproduction of video was terribly slow. I repeat every frame about 7 times and audio kept repeating too.
It’s weird that players such as kaffeine and vlc don’t work right. But my pc is not all that out-of-date. You may see its description on this thread.
And what is more strange is that on my first install of opensuse 11.4 that was a gnome install, where I later added kde, kaffeine worked right to play dvd, it was only slow to start the video after clicking on a menu item. And vlc was almost the same way.
After a while I felt that I no longer used gnome so to save space and keep system clean I made a fresh kde install. From that on I began to have issues with dvd’s.
Does anyone know what difference there may be between a gnome install with kde added later and a fresh kde install so that I started to have the problems above with the second one?

Martin, if I thought that the order of installing desktops made any difference, I would just do a clean install. I use KDE, but I install GNOME and a couple others as well. In the end, it sounds like some sort of hardware issue to me. I try to do a clean install of openSUSE, install only 64 bit and install the nVIDIA proprietary video driver. Since I wrote mmcheck, I follow its advice. I also have a Dell laptop (from my work) with Intel video, openSUSE and 64 bit. My best computer can compile a kernel in 8 minutes and my laptop takes 38 minutes. Even so, I can play any DVD or look at iTunes movie trailers without any problem on both computers. While there could be a defect or some hardware problem of yours that is just not supported in Linux, I don’t think placing your frustration in huge bold letters in a message here is going to make any difference. Consider the advice you have received before and perhaps start over and see if that helps.

Thank You,

I used huge letter not to express rage but because I myself have read long threads before anhd it’s hard for readers to find what are the important points in the middle of many comments. So when I made questions I consider important I used large size to catch the attention of readers. Excuse me for any bad impression.
I tried to apply every counsel I received here. I just can’t use 64-bits because my pc is 64-bits. But I used mmcheck and installed everything it suggested.
As I mentioned only Mplayer based software seem to work fine but without dvd menus. In smplayer menus there is an option related to dvd menu but it’s always turned off.
Today I even tried to create a new user to see if there was some misconfiguration. But that didn’t work too.
Would it help if I switched nvidia settings to performance, quality or high quality? Should I change kde settings too? Or may it be helpful to mes with any buffer configuration in any application?

Now a according to this link: List of Intel Pentium Dual-Core microprocessors - Wikipedia, the free encyclopedia, a Pentium Dual core is 64 bit. Please look at it and tell me if this is the right CPU or not. As for nVIDIA, the most recent driver is 280.13. Have you installed the most recent driver? A while ago, I remember seeing a bunch of people having a problem using nVIDIA and 32 bit KDE and perhaps you are seeing this problem though I guess I thought the most recent nVIDIA driver version did not have this issue. As for nvidia settings to performance, quality or high quality, I don’t recall seeing those options with Linux driver, but recall them with the Windows driver.

Thank You,

I got very surprised. Mine is a Intel dual-core E2160. According to intel it really is 64-bit! And I never knew about it!
But what else do I need. Having a 64-bit if I install opensuse 64-bit will all my system and pc work like a 64-bit one? Or do I need specific motherboard, hd, usb, dvd-drive and so on to make my pc work like 64-bit?
About nvidia driver I use the proprietary one from nvidia repo for opensuse. There the latest available version is 275.21. There’s no 280.13 in the repo.
And in nvidia settings (available at kmenu/ system/ configuration) there’s an opengl settings option where we can choose among performance, quality and high quality. There are also many other options under xcreen and gpu that I left by default because I don’t know what they mean.

I got very surprised. Mine is a Intel dual-core E2160. According to intel it really is 64-bit! And I never knew about it!
But what else do I need. Having a 64-bit if I install opensuse 64-bit will all my system and pc work like a 64-bit one? Or do I need specific motherboard, hd, usb, dvd-drive and so on to make my pc work like 64-bit?
About nvidia driver I use the proprietary one from nvidia repo for opensuse. There the latest available version is 275.21. There’s no 280.13 in the repo.
And in nvidia settings (available at kmenu/ system/ configuration) there’s an opengl settings option where we can choose among performance, quality and high quality. There are also many other options under xcreen and gpu that I left by default because I don’t know what they mean.

As for the 32/64 bit thing, there is nothing to change on your hardware. Just download the 64 bit version of openSUSE, boot from the disk and do a clean install over your old openSUSE. If you did create a separate /home partition, elect to mount it only, do not reformat it and your settings will be maintained. Like any clean install, you must reinstall all software that you had before, but your personnel settings will be reused. Further, when you boot from the 64 bit DVD, if you really have only a 32 bit system, it will not install and nothing will be messed up by trying.

As for getting the most recent version of the nVIDIA proprietary video driver I suggest you install it the hard way which means you don’t wait or hope it shows up in the repo. If you are going to reinstall openSUSE, you might as well go for the MAX and install the most resent video driver. Please look at my blog on the subject.

Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums

Keep in mind that when using the nVIDIA driver, you must add in the kernel load option nomodeset to your Grub /boot/grub/menu.lst file as root and blacklist the nouveau driver in the file /etc/modprobe.d/50-blacklist.conf file as root. If you get the 64 bit version of openSUSE loaded, you may need to add the nomodeset kernel option to get a steady picture. Just read the above blog and all pointers for more information on the loading of the nVIDIA driver.

Thank You,

Thanks.
Well, now that 12.1 is in the 3rd milestone I think it’s waste of time to do a fresh install of 11.4. I’ll try to hold on this way up to 12.1 and so try 64-bit.

Thanks.
Well, now that 12.1 is in the 3rd milestone I think it’s waste of time to do a fresh install of 11.4. I’ll try to hold on this way up to 12.1 and so try 64-bit.

So, consider that openSUSE 12.1 is still not in final release and can contain a higher than normal problem listing. I have installed openSUSE 12.1 M5 into VirtualBox and it is working just fine. Still, I see issues pop up with this pre-release. We do encourage users to post any problems they have with pre-release software like openSUSE 12.1. There is a beta/pre-release forum to talk about such issues and Good Luck!

Thank You,