What is KVM?

I see this during boot:

kvm disabled by bios

Or maybe it was

kvm disabled in bios

but you get the idea. I think it’s got something to do with virtual machines, not sure, but that’s why I posted this here. I use VirtualBox, it works fine, so it apparently isn’t a problem. I was just curious. I see it on my laptop, too (I have VirtualBox on that also). I don’t think I want to “fix” this, I was just wondering what it means.

I used to see that message. So I went into BIOS settings and enabled the virtualization support. I don’t remember what it was called in BIOS settings.

This enables additional processor functions (probably an addition set of instructions that can be used).

Beyond that, KVM is a way of handling virtualization that is fully supported by open source. I’m using it from time to time, though on a different computer. I am unable to compare it to virtualbox, because I have never tried virtualbox.

I’m not sure, but if you turn on the KVM support in your BIOS, then virtualbox might be able to use that for slightly greater efficiency.

The hardware virtualization support in the processor is something that you
sometimes need to enable, and the only reason I remember needing to do so
was for x86_64 virtualization, meaning even though you likely have an
x86_64 host, if you wanted to do run x86_64 VMs then you had to have the
processor support; this was a problem back when x86_64 was relatively new
because the first Intel processors did NOT include it, thus the company I
was at happily bought the AMDs that came with it, and that helped
duplicate those new x86_64 systems in a virtual environment.

Why in the world that would not be a default today is beyond me, but since
KVM does hardware virtualization I can see why it would be needed. I’ve
never noticed a problem disabling it, and I’ve used both Virtualbox and
KVM (at the same time, with VMware too) on a single laptop (this one, as
well as the previous one), though I primarily use KVM now.

Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below.

If you want to send me a private message, please let me know in the
forum as I do not use the web interface often.

As to why CPU virtualization extensions aren’t enabled by default,
I’d guess that it’s generally recognized that enabling greatly enlarges the attack surface (risk against hacking) and the consequences of an exploit of this kind of vulnerability strikes at the core of practically everything the CPU touches. That said, there have been only a couple vulnerabilities I’m aware of and published in the many, many years these extensions have existed. Because they can provide a vector to core processing, security is extra high.

But, as to the @OP question,
It is peculiar that a Google search returns hits of people who boot up systems with no virtualization installed, so there wouldn’t be a need to enable the setting. It’s probably some glitch in some system builds to assume that kvm is installed when it isn’t.

I’ve never seen it on an openSUSE, but then most of the machines I work with use virtualization in some way so what I regularly have seen over the years might be skewed. If anyone sees this error on an openSUSE, you should probably report it to https://bugzilla.opensuse.org as a minor error, be sure to include detailed technical information about your hardware, what your BIOS virtualization setting is, and what virtualization you have installed if any.


I did some searching last night, and found that with VirtualBox, it can cause problems. I forget what problems, though, but I don’t seem to need it anyway, VB works fine for what little I do with it. Better to not try to “fix” anything, I learned that the hard way in the pastlol!

I don’t find it explicitly stated,
But the “Requirements for 64-bit” in the Virtualbox documentation infers that without CPU extensions, no 64-bit Guests are supported, only 32-bit.
Conversely, if CPU extensions are enabled, even if your HostOS is 32-bit, you can install and run 64-bit Guests.


I only use it for WinXP 32 bit and Win2000 32 bit, but that’s good to know.

If you have the disk space,
Try installing a 32-bit TW Guest…
Or, enable the CPU extensions and install another LEAP…

You might find the experience enlightening and intriguing…
The idea you can do anything, even something risky and experimental without any fear of destroying a valued system.