What is going wrong with oxygen-icon-theme?

Recently, I tried to add VLC to my openSUSE 13.1 EEE PC netbook. Yast locked up downloading the oxygen-icon-theme. Apparently it’s needed as a dependency. The distro wasn’t working very well anyway, so I tried a new net install of 13.1. Yast locked up downloading oxygen-icon-theme, and the install will not progress from there. On a different machine, a 64bit Athlon II under Virtualbox, I ran a simple online update. Yast packed up on guess what? Downloading oxygen-icon-theme. Something is wrong here! These machines have nothing in common, not even the same (yes I ran md5sum) DVDs. Why would they all lock upwhen they come to the download oxygen-icon-theme line?

More information. My big box runs 12.3, not 13.1 as above. I tried to install oxygen-icon-theme alone, and Yast crashed again. Nothing short of a kill -9 (pid) will return control.

How and where are you downloading from?

The default repository for the website downloads, I guess, for the 13.1 install DVDs. For my 12.3 main machine, it’s from download.opensuse.org, download.videolan.org, ftp.gwdg.de, and opensuse-guide.org.

Still confused are you using zypper/yast/appr??? Or are you actually downloading from the repo via wec browser or ftp or…

Yast for the big machine, the net install disk for the netbook.

After I made my first post, I tried installing the oxygen-icon-theme by itself. No luck. Yast again locks up solid. The two machines couldn’t be more different, but in all instances oxygen-icon-theme locked up in the same place, about 92% finished.

I’m going to try the 13.1 net install like you did and see if I can reproduce your errors. In the meantime, try switching mirrors? I dont know about how the installer does this and if it even matters but maybe the mirror you are defaulting to has corrupt files or something?

Thanks! I just “discovered” the f4 alternate server feature, which I would have tried had I found it first. Now I’m off to find one of those alternate addresses. The install just has the one download.opensuse.org default.

f4 feature doesn’t “find” the entered mirror. It seems to be inextricably mixed in with the wireless configuration, which I do not use.

I’ll be back later to try again.

Well I am running it now and so far no issues. Here you can see I successfully installed oxygen-icon-theme in the VM.

I am using virtualbox with the 64bit version of the OS


Thanks for the help so far! Here is where I am right now:

On my EEE PC 32bit netbook, I figured out how to connect thru the NIC rather than the wireless, but when I substitute repositories, the 13.1 net install will not “find” them. I have tried several repos from around the world. The default install still freezes at “Downloading oxygen-icon-theme” at 97% (Reported in error as 92% above).

On my Athlon II 64bit, existing 12.3 system under VirtualBox, Yast will lock up while loading “Downloading oxygen-icon-theme” at 97% as well. I will admit to being a little confused about changing the repository under Yast, and don’t want to bork up my system by trying.

Two different distros, one a new install, the other an existing system, two completely different machines, but they both die at “Downloading oxygen-icon-theme” at 97%. This has been happening for over a week now. I would think any errors in the repository would have been found by now. If someone will suggest how to safely try changing repos on my big machine, I’ll give it a try. Other than that, I’m stumped!

Well I guess no on else is seeing this so it seem specific to you. What country? maybe the ISP is filter to heavy handedly???

In any case it is very strange.

Perhaps the iso image you downloaded is corrupted? :question:

Is this where you got it from? http://download.opensuse.org/distribution/13.1/iso/openSUSE-13.1-NET-x86_64.iso

Yes, right from software.opensuse.org: Download openSUSE 13.1, except the install is the 32-bit iso. I checked it with md5sum, and also the “Check Installation Media” test on the disk.

USA. Very strange! My ISP is pretty cool. I haven’t had any problems with them over seven or eight years.

MMM there does seem to be trouble with some other things in 32 bit. There are several threads about it. I don’t think it gets the testing that it may have used to since most seem to use 64 bit these days. Worth a bugzilla post I guess.

openSUSE:Submitting bug reports - openSUSE

Be sure to say you run 32 bit

I don’t think there’s enough info to file a report yet. And this does happen on the 64 bit, and both 12.3 and 13.1 distros too.

It must be something on your end though. Is there anything you are configuring with the installer or maybe something special about your network configuration?

I almost agree, but no, everything is plain vanilla generic. Both systems, and the network and the ISP have been used with several other OSs. New installs fail for a lot of reasons, and I probably would have shrugged this off and gone with some other distro, except it happens in exactly the same spot as on my 64bit machine, during an ordinary update. Now, the machine indicates that it is updated, when I am sure it isn’t. Yast never completed. There was more software to load when Yast packed up.

I think a good test would be to reset Yast on the 64bit, and have it check everything. I haven’t found how to do that yet, and imagine it does a check automatically during that thirty seconds or so while it loads? On the netbook install, I’m stumped.

I’ve been digging around thru the documentation, and have done a ‘zypper ref’ refresh. I don’t see much else that can be done as far as a checking my 64 bit system for integrity. I suppose that whatever package called oxygen-icon-theme as a dependency has been resolved, somehow.

For my netbook, I’m downloading another distro. We’ll see how well that one works out.