What is going on with Leap 15 repository???


What’s going on with the opensuse leap 15.0 repository?
Yesterday I wanted to upgrade my packages (about 150 packages to update) but had no time.
Today almost all packages shows me that on the server there is a older version as my installed versions…

I see the same here on the OSS repository.

And the OSS Update repo seems to be empty.

Better not do any updates for the moment.

I thought a bit over this. My interpretation is that because the Update repo being empty, all packages that were updated from it since LEAP 15.0 is released are now shown in read (in YaST > Software), because their version number can only be compaired to the original version on the OSS repo (those are never changed after release, all changes go in the UPdate repo).

So IMHO the real problem is the OSS Update repo being empty.

I tried to contact people at openSUSE about this.

Seems a bug report was raised earlier today:


Yes, seeing the same thing.

I updated last evening (at around 0200 UTC March 22), and everything seemed okay at that time. But now the update repo is empty.

That is fine. I knocked at another door. Let us hope that using several roads will increase the ETO of the solution.

Just receivd this:

Thanks for the report, we are already working on it.

Sounds positive.

I see there is a banner message on top of the forums pages now.

We can only wait it out now :wink:

Thanks all, specialy @tkmbe for reporting.

Checking, a few minutes ago, things seemed back to normal.

Of course, that might have been luck in the mirror that I was redirected to. But at least it is better than my prior check.

From the Factory ML:


Due to a internal problem the update repository for 15.0 is currently empty.

We are restoring it currently and it should be available again soon.

Ciao, Marcus

I also see the OSS Update repo populated again.

The status page hasn’t changed though, thus it maybe that they are still doing things and checking if everything is OK.

Give them (and yourself) a bit more time and do not start using something that might not be complete yet.

I get the same type of issue when trying to update my leap 15. Invalid checksum/ wrong digest.
Is there a fix yet?

“try to update” is not containing much technical information.

I just did a YaST > Software > Online Update (the equivalwent of zypper patch) and it run without a glitch.

Please do

zypper clean
zypper ref
zypper up

Still getting “Wrong Digest” message when starting the first update after a new install of Leap 15. This is just for the libpackagekit rpm. Is it safe to ignore the warning?

You use PackageKit?

Better try

zypper up

or YaST > Software.

That would bring you in line with what most people here use and thus make it easier to trouble shoot your problems.

*You use PackageKit?

No, but Yast has PackageKit on the update list. It was the package that threw the “Wrong Digest” message. I use Yast, almost exclusively.

The command zypper up has problems too:


I have deleted a message by accident, while trying to cancel an edit.
What I said was that the “Wrong Digest” message came up first when Yast was doing an on-line update and had downloaded libpackagekit. No, I don’t generally use packagekit, almost always using Yast.
Tried the zypper up command, which had similar problems with the error check–not a match.
So, have a new install of Leap 15 and can’t update it.
(as an aside, this page of the Forum seems to lose content in Konqueror when previewing a post. Using Konqueror temporarily because the un-updated Firefox crashes repeatedly)

You should also read this one: https://forums.opensuse.org/showthread.php/535376-libuuid-devel-Yast-reporting-wrong-digest-(checksums-don-t-match)?p=2897967#post2897967

It will give you some more information about the problem. You are not alone and as there are multiple reports, also in the mailing lists, you can expect that people are working on it. But it is still Sunday, so I guess it will be Monday (and probably the time zones of the Amrican continent) before it will be solved.