What Is Causing Recent DVD Problems?

Until recently, on Suse 11.0 and lower (10.3, 10.2) DVDs played just fine on all my computers. When I recently tried 11.1 - and didn’t like it, I re-installed 11.0 on my laptop (with KDE3) but I’ve lost any way to play DVDs. (It’s the ability/permission to access the file problem)

This is despite having several computers running 11.0 and playing DVDs just fine. Unfortunately these are all 32 bit desktops and I can’t just copy the install from them to my 64 bit laptop - a Lenovo T-61.

All of this has happened since Germany passed laws making Packman remove key files from their repo, like libdvdcss.

I’ve followed the multimedia install guides and have had no success. (And that included installing 11.1 with KDE3, 11.1 with KDE4, etc)

So yesterday, I began comparing the versions of what is installed on my desktop 32 bit system from last summer, and what is installed on my laptop.

Kaffeine, for example, uses the 8.7-0 version on the desktop that works, and 8.7-2 is what’s in the packman repos. The kdemultimedia programs that worked were version 3.5.9-43.1 and what packman has are 3.5.9-44. The libavcodec52 in the desktop that shows DVDs is version and the one I get from packman is There are some other files that are obviously different versions, too.

The making DVDs play problem seems to be all over, too, with lots of posts in other distros with the same sorts of problems we’re having with suse. And these aren’t the usual problems where you just need to add libdvdcss, either.

So, as a non-programmer, I’d like to pose some questions.

Can this be related to the mix of KDE3 and KDE4 files that are evident even if you don’t install KDE4 at all, so that somehow we’re trying to use the wrong file?

Is the current version of kaffeine on packman crippled somehow?

Is there a way to get previous versions of the software?

I’d hate to revert to 10.3 after all the improvements made to 11.0, especially in yast, but if the problem is in kDE would it make any difference?

Is there any signifigance to having the problems pop up right after 11.1 came out? Was there some change made to 11.0 at the same time we’re not aware of?

All this may be idle speculation on my part, but not having your equipment work leads to it, I suppose. Any thoughts?