What happens to a program installation?

Hi,

I install a program as a superuser. It has a problem (it does not look like as expected). When I check it with “ps” command. It echoes:
[1]+ Stopped ./ccs_setup_5.3.0.00090.bin

but the program “ccs_setup_5.3.0.00090.bin” seems stay there in later ps check.

Could you explain what happens? ccs_setup_5.3.0.00090.bin is not in normal installation? Thanks,


linux-iu5j:/tmp/ccsv5_install/CCS5.3.0.00090_linux # ps
PID TTY TIME CMD
6381 pts/0 00:00:00 sudo
6382 pts/0 00:00:00 bash
6421 pts/0 00:00:00 ps
linux-iu5j:/tmp/ccsv5_install/CCS5.3.0.00090_linux # ./ccs_setup_5.3.0.00090.bin &
[1] 6422
linux-iu5j:/tmp/ccsv5_install/CCS5.3.0.00090_linux # ps
PID TTY TIME CMD
6381 pts/0 00:00:00 sudo
6382 pts/0 00:00:00 bash
6422 pts/0 00:00:00 ccs_setup_5.3.0
6426 pts/0 00:00:00 stty
6427 pts/0 00:00:00 ps

[1]+ Stopped ./ccs_setup_5.3.0.00090.bin
linux-iu5j:/tmp/ccsv5_install/CCS5.3.0.00090_linux # ps
PID TTY TIME CMD
6381 pts/0 00:00:00 sudo
6382 pts/0 00:00:00 bash
6422 pts/0 00:00:00 ccs_setup_5.3.0
6426 pts/0 00:00:00 stty
6428 pts/0 00:00:00 ps
linux-iu5j:/tmp/ccsv5_install/CCS5.3.0.00090_linux # ps
PID TTY TIME CMD
6381 pts/0 00:00:00 sudo
6382 pts/0 00:00:00 bash
6422 pts/0 00:00:00 ccs_setup_5.3.0
6426 pts/0 00:00:00 stty
6429 pts/0 00:00:00 ps
linux-iu5j:/tmp/ccsv5_install/CCS5.3.0.00090_linux #

First: please always state your openSUSE version
Second: this does not say much more than that the installer is still running. I wonder what exactly you did. What you mean by “didn’t look like”.
Furthermore, I don’t know what software is concerned, where you got it from and if it’s made to run on openSUSE. If the latter is the case, did you check software.opensuse.org: Download openSUSE 12.2 to see if packages are available for openSUSE?

On 01/12/2013 04:26 PM, freerjw wrote:
> [1]+ Stopped ./ccs_setup_5.3.0.00090.bin
>
> but the program “ccs_setup_5.3.0.00090.bin” seems stay there in later
> ps check.

don’t confuse “Stopped” with “Waiting” or “Quit” or “Shut down normally”
or etc…

the process exists, but for some reason is ‘stopped’ doing its work,
maybe it is a zombie…crank up top and have a look at it…

or, you might look in the logs and see if a reason for the ‘stopping’ is
given…

answer Knurpht’s questions…you question prompts more questions than
answers!


dd

On 2013-01-12 16:26, freerjw wrote:
>
> Hi,
>
> I install a program as a superuser. It has a problem (it does not look
> like as expected). When I check it with “ps” command. It echoes:
> [1]+ Stopped ./ccs_setup_5.3.0.00090.bin

GOSH! This is the third time you ask this in three different posts.

This are the other two posts I remember:


<http://forums.opensuse.org/showthread.php?t=482173>
<http://forums.opensuse.org/showthread.php?t=482215>

How many answers do you want?


Cheers/Saludos
Carlos E. R. (12.1 test at Minas-Anor)