WG111v2 - 11.1 Fears

I am becoming rather concerned about support for my WG111v2 USB Wireless adapter in openSUSE 11.1. It works sort of fine in 11.0, though it’s a pain to get connected. I recently tried Fedora 10 and found that, though my card was detected and connected in short order, I got 15-19% signal, whereas I currently get 90-95% (my router is only feet away from the pc). I just tried the openSUSE 11.1RC1 LiveCD and found the same was true for it (easy connection, low signal). I suspect this may have something to do with the kernel module itself (rtl8187), as Fedora 10 and openSUSE 11.1 use the same kernel version.

Does anyone know what I can expect for the final GM?

I should clarify, is this an issue with openSUSE 11.1 or with the 2.6.27 kernel? Should I be filing a bug report? Or am I back to ndis-land ?

As root do “iwconfig” and look at the “rate” & strength ratio

“man iwconfig”

In the past & not your device, I have experienced different results with different drivers. I could do best with an OEM driver. You should check;) And also check for documentation for implementing it.

For mine, I had to compile the (OEM) kernel module, rm the kernel module & modprobe the new driver.

It’s not that hard & you should expect 91/100 & 54M with a good driver.

I recommend searching google/linux <Linux> - Google Search](http://www.google.com/linux) for your device, and also, check the HCLs (hardware compatibility lists),i.e., search.