WEP wlan not working with 11.1


Another issue after migrating to openSUSE 11.1: my card wont connect to my home WLAN with simple WEP security.

My card is a:

02:0b.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)
        Subsystem: Intel Corporation Device 2751
        Flags: bus master, medium devsel, latency 64, IRQ 9
        Memory at d0206000 (32-bit, non-prefetchable) [size=4]
        Capabilities: [dc] Power Management version 2
        Kernel driver in use: ipw2200
        Kernel modules: ipw2200

The settings are as simple as can be on my router:

WEP (Wired Equivalent Privacy)
Open System Authentication Type
64 bit Encryption Strength
Using a HEX password

Now i know the kernel/modules recognize the hardware fine because:

raziel:/etc/X11 # iwlist eth1 scan
eth1      Scan completed : 
          Cell 02 - Address: 00:14:6C:67:CF:5C                           
                    Protocol:IEEE 802.11bg                               
                    Frequency:2.432 GHz (Channel 5)                      
                    Encryption key:on                                    
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s   
                              11 Mb/s; 12 Mb/s; 18 Mb/s; 22 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Quality=71/100  Signal level=-34 dBm
                    Extra: Last beacon: 116ms ago


As you can see, my home wlan essid is detected, but when i use YaST to connect to it it just plain wont work; cant get a DHCP config or even a static IP rolling.

My steps:

Made sure WEP was selected in Open Mode and with 64 bit encryption and i have tried setting the Operating Mode both ih Ad-Hoc and in Managed. No luck.
Also tried to change the Key input type to all three kinds: Passphrase, ASCII and Hex (of course making sure my config matched my router’s); with no luck still.
Even specified on which channel the ESSID is broadcasting; again nothing.

Any suggestions on what else to do?[/size]

The same thing about WPA. I’ve just installed opensuse 11.1 and waste a day trying to make my usb-wifi work (d-link DWL-G122 ver. B1). In the end I’ve recognized that driver had been working from the very beginning, out of box. And the problem is in WPA encryption. Unsecured wifi connection works fine.

Hello, had the same issue …

Using ARtem WiFi Pcmcia Card with Orinico Chip Set
together with Suse 11.1 Gnome Desktop

Connection with access point works fine if encryption is turned of
MAC address filter, DHCP etc. activ and working, SSID hidden

but as I was switching on WEP (my WiFi doesn’t support WPA) the connection was dropped.

I recognized that the WEP key entered in the network-manager-applet 0.7.0 which is started from Gnome panel changed after the screen poped back on the screen re-requesting the key.

All things entered are changed from ascii to hex representation and doubled in count. There is a checkbox available to make the key visible.

I now configured WEP 64bit, open, infrastructure by taking the changed key (which was 10 chars hex) and configured my access point using hex while typing again the original 5 char ascii into the panel application and it worked.

I guess the same will work for WEP 128 bit by using 13 char ascii / 26 char hex but haven’t tested it because I am relying on the wifi connection right now.

Good luck, rhonin

The same problem here with atheros WiFi. I can change my home network settings so everythink works fine, the real problem is to connect at some other places… (at friends, conference etc.) where I can not change the network.

I found that I can’t connect to WEP wlan network in kde4 desktop.
So I change networkmanager frontend to nm-applet.
Now the wlan works fine.
Just remove NetworkManager-kde and install NetworkManager-gnome,
and link /usr/bin/nm-applet to ~/.kde4/Autostart/