WEP Key type (pass, ascii, hex) functioning wrong

Hi. My connection is now working fine, but I was just lucky to find what was the right way to enter the wep-key.

This was a case of Managed connection with a wep-key under 11.3 using iwconfig but through Yast.

On every try, I checked iwconfig and yes, the access point was identified even if the key was wrong, but in all cases if the key was wrong, I had no assigned IP of course.

The way the key had to be keyed in was hexadecimal, but this is precisely the strange way to input this key which was only allowed:

I had to put the radiobutton for type of key (pass, ascii or hex) in anything except hex
Then type the key (the one printed under the router) which was a sequence without dashes XXXXXXXXXX was the key. By this time, the router had already been detected

Once I had keyed in this key, then I could move the radiobutton to hexadecimal and then press finish.

This was the successful way and I tried it in all other ways without success. I set up 2 machines and only this way worked. Pitty because the windows machines around just asked users for a key without type (hex, ascii, password, no dashes) and they did not have to hack.

When I was leaving the radiobutton in “hex” then it only accepted keys in the format 0000-0000-0000-0000-0000-0000-00 (I think it was this long, six sets of four digits separated by dashes plus one last set of 2 digits separated from the previous chain by a dash). I tried padding my smaller number with zeroes on both sides, etc., Of course resulting wrong.

My not dashed key was in the end dashed internally but converted to XXXX-XXXX-XX without anything else afterwards, but to get to this, the trick of typing as not hex and once finished, moving the radio to hex, was the solution

This seems to me like a buggy screen and should take anything in any form to internally try in all manners saving the silly person from the also silly hacking. :stuck_out_tongue:

Warm Regards