WeirdNetworkID

Hi

new to Linux so excuse me if its a stupid question.

When I look for my Linux Share in Windows Explorer (from XP) the Computer is identified as

samba 3.4.2-1.3.1-2229-suse-sl11.2 (DocStore)

I would prefer it to be just DocStore or at least something shorter.

Any help appreciated.

Thanks

Peter :slight_smile:

In Linux, your Samba smb.conf file, located in the folder /etc/samba, are two values that set your “netbios name” and “server string” and look like this in my smb.conf file:


	netbios name = LINUXMASTER
	server string = Master of the Universe

If I saw a XP computer that showed a Linux computer running Samba as “samba 3.4.2-1.3.1-2229-suse-sl11.2 (DocStore)”, I might wonder if the netbios name is set to “samba 3.4.2-1.3.1-2229-suse-sl11.2” and the server string is set to “DocStore”, but this would be backwards from normal. I suggest you might use the following setup, based on what was said in your message:


	netbios name = DocStore
	server string = Linux

In order to change the smb.conf file. I might suggest you look at my Samba writeup at the forum location:

Samba SMB file sharing in openSUSE 11.2 - openSUSE Forums

Thank You,

Put this line in the [global] stanza of the config file (smb.conf) located at /etc/samba/smb.conf:

server string =

then reboot and see what comes up. If you don’t like what comes up then put this line also into the [global] stanza:

netbios name = DocStore

and rebooot again (both machines).

On Thu June 10 2010 07:26 pm, jdmcdaniel3 wrote:

>
> In Linux, your Samba smb.conf file, located in the folder /etc/samba,
> are two values that set your “netbios name” and “server string” and look
> like this in my smb.conf file:
>
> Code:
> --------------------
>
> netbios name = LINUXMASTER
> server string = Master of the Universe
>
> --------------------
>
>
> If I saw a XP computer that showed a Linux computer running Samba as
> “samba 3.4.2-1.3.1-2229-suse-sl11.2 (DocStore)”, I might wonder if the
> netbios name is set to “samba 3.4.2-1.3.1-2229-suse-sl11.2” and the
> server string is set to “DocStore”, but this would be backwards from
> normal. I suggest you might use the following setup, based on what was
> said in your message:
<snip>
>
> Thank You,
>
>
jdmcdaniel3 & voodooman2;

Since a Netbios name is limited to 15 characters, clearly “samba…” could not
be the netbios name. It is in fact the default server string of a Suse Samba
install. You can reset the server string as you have suggested, but XP has
cached the old server string and it is difficult to make it go away. On XP
you will find this value cached in the directory
“Documents and Settings&lt;username>\Nethood”. It could also be somewhere in
ntuser.dat but I’m not sure about that.

By default the netbios name of the Samba server defaults to the hostname.
Unless there is a reason you do not want the hostname and netbios name to
coincide, there is really no need to set the netbios name in your smb.conf.
Of course if your hostname is longer than 15 characters or has characters not
allowed by netbios then you will want to set that parameter.


P. V.
“We’re all in this together, I’m pulling for you.” Red Green

Hi

thanks for all your replies, I will look at this later.

I am new to Linux but not computers. I have been in the computer business since 1992.

My experience so far with Linux has been fraught. I need to replace a freeNAS box as there are issues with Win7. So far I have tried.

Kubuntu - couldnt set up a raid. Although the network setup was much easier than oSuse (I had problems sharing with oS).

ClearOS - couldnt load it, install just hung.

Open Filer, the web interface wasnt fully operational.

I now have OpenSuse actually working - looks good.

Thanks

Peter

Hi

thanks for taking the time to help me , very much appreciated.

Followed your advice and it worked!!!

Regards

Peter :):):slight_smile:

FYI for more on tweaking the setup have a read of this:
Samba and Suse: HowTo Set up an openSUSE-Windows Home Office LAN/Network. Versions 11.x