Weird X behavior after upgrading to 11.4

This is my first post here. I never needed any kind of help with 11.3, maybe due the fact I installed it several months after its release. With the new 11.4 release I noticed a couple strange things:

  • After starting certain applications (most common is LibreOffice) the entire desktop gets pixelated and unusable.
  • The screen blinks randomly.
    I’m using a Asus Motherboard with an ATI Radeon X1200 Series integrated graphic card.
    What can I do? I tried to find an answer using the search function but didn’t find anything.
    Thank you very much in advance,
    Luis Pablo

Something like this other report?

Display flickers unusably with 11.4 installation

Something similar to that report but the most strange thing is the relation between this bug and certain apps like LibreOffice (more specifically LibreOffice Calc). I tried the nomodeset solution before posting and I tried again in order to share the output:
Failed services in runlevel 5: vboxadd vmtoolsd
Skipped services in runlevel 5: nfs cifs
With the “nomodeset” addition I’m unable to start runlevel 5.

Also I was not able to find System Settings >> Startup and Shutdown >> Service Manager >> Disable ‘Display management change monitor’
The most similar thing I found was ‘Quick X Display Manager’. Will this solve the issue?

It’s under KDE System Settings > Advanced > Service Manager. Might be somewhere else in GNOME.

AFICT that Display management change monitor enables the system to detect when monitors are plugged and unplugged, or a Fn key is used to switch monitors. I don’t believe it touches the heart of the problem. But I don’t have any answers, I’m just collecting more evidence.