weird wake on lan problem

Hi all,

I’m having a weird problem while trying to configure wake on lan on suse.

WOL actually works when I hibernate Windows (it does not work with the PC turned off), but it doesn’t work when I suspend Suse to ram or disk. The ethtool shows wol is enabled, and I have already tryed with and without the arp routing set up via telnet on my router. I have also tried changing the energy saving options in every way I could. Port for wol is also open both on the router and firewall, but I think this may be unnecessary.

Any idea on what may be the problem? Please just ask if you need any other info from my system.

Thanks a lot!

I also didn’t manage to wake up two computers using wol, even though the ethtool reports wol to be in mode “g” (magic packet).

The next thing I’ll try when I have time is to re-set the wol mode using: ethtool -s eth0 wol g

You might try that as well.

Ok, the problem is solved in my case.

The machine is a Dell Dimension 8300N with the onboard NIC, and wake up on lan was not working correctly (it only worked when hibernated from Windows, but in any case when it was done on Linux).

Like four years ago, some guy managed to set up the WOL option in the bios (this option doesn’t appear on the menu) using a Dell Configuration Utility v.1.1 not designed for Dimension’s (Enabling wake up on Lan in Dimension 8300 - DELL COMMUNITY).

I tried that but the file was no longer available and I couldn’t set it up with the newer version. Fortunately, you can still get v.1.2 at (I used DCCU12A00.exe).

After getting all the system variables with the utility and running the file generated, I could load them and change the WakeupOnLAN parameter to the ‘enabled for all NICs’ option. Then you only have to save this change to a new file and execute it. You cannot change the WakeupOnLANmethod parameter, but after a reboot you’ll see that it has changed to ‘magic packet’ if you get all the system variables again.

I did this under Windows, so I’m not sure that you can run it with wine.

WOL works now with the computer shutted down, and when it is suspended to disk (but not when it’s suspended to RAM). Good enough for me :slight_smile:

I post this here so the solution is available for people with the same hardware. All credits for the original poster at Enabling wake up on Lan in Dimension 8300 - DELL COMMUNITY :wink:

edit: this turned out to be a hardware/bios config problem, so a mod can move the post to the right section if he or she feels like doing so