weird touchpad behaviour

my HP dv4 touchpad thinks its a touchscreen, well with out the screen. it behaves in a the manner where u are suppose move the cursor around like normal pads, but where ever i touch on the pad it move to represented area on the screen, with left click.
if i touch the top left corner of the pad the cursor jumps to the top left corner of the screen, i touch the middle of the pad, the cursor jump to the middle.

i am totally lost as to where to start.

after some troubleshooting, i found the problem to be associated with the kde4 mouse config, it works perfectly fine with gnome and during install. i did not noticed it until i had my mouse disconnected and was forced to used touchpad.
if someone is having the same issue please say something so we can work on it to fix this

You can try setting it to a a default usb mouse driver in YaST.

That worked for me on 11.0 for my synaptics touchpad that was doing some strange scrolling behaviour.
Another thing that worked was grabbing the latest version of x11-input-synaptics driver from Webpin but since my touchpad is working better than ever in 11.1 I don’t need to do either of those 2 anymore… I’m guessing the webkit version got intergrated into 11.1 so that might not be useful anymore.

Anyways, try setting it as a default usb mouse think that should nearly always work (although it kills off the scrolling behaviour when sliding your finger down the sides)

i am using SUSE 11.0 KDE 4.0 , i had also same problem with my touch pad. As you had given the link , i open that link, when i am trying to install that software , i am getting error.

An error occurred while initializing the software repository
20090206-052315: Failed to cache repo (3).
History: “/var/cache/zypp/raw/20090206-52315”>"/var/cache/zypp/solv/20090206-052315/solv" /usr/bin/ line 45: mktemp : command not found

Try again ?

Can’t test to see if I have the same problem as I’m on 11.1. so it tells me

The install link or file you opened does not contain instructions for this version of openSUSE.

You could try to install it manually by adding the repository above the one click to YaST software management > repositories.
Then in YaST software management look up x11-input and install it.

Or as it suggested, try again later.

Weird touchpad behaviour really doesn’t describe it well, but does let me feel I’m in the right area to discuss.

When I boot into 11.1 KDE 3.5 for stability as 4 has had too many crashes for me, I immediatly run this command…

$ synclient TouchpadOff=1

This kills the evil touchpad for the session so the USB optical mouse works without event!

There is another issue that has cropped up in the last few days.
As this XPS M1330 Dell laptop with 2.5Ghz and 4GB with Nvidia GeForceM GS chip (new motherboard as last chip melted) dual boot XP/openSUSE 11.1 KDE 3.5.

When editing text files in Linux I will save the file and run the program and errors will occur with program halt.
I will go back into the config file I had just edited and find the last CTRL-C command ( “<SIL>” ) is there in several wrong places.
Strangely, I had not used any copy commands or “CTRL-C” while editing this config file.

I noticed this type of behaviour in a number of files and realized this is exactly the same type of behaviour the touchpad used before I turn it off each boot.

Is it possible it is not the Touchpad but another program that causes a type of “hyper-activity” of the input devices such as touchpads, mice, and keyboards where memory or CPU interact with them???

I’m trying to get to the bottom of this very, very strange situation.


There is one other possibility and I am going crazy!?#???rotfl!

On the Xps, I had a similar problem my solution though was by adding a parameter to the kernel at boot :


I’m not sure if it did the same under gnome. :frowning: