Weird system power offs

Hi all. I’m a total Linux rookie so forgive me if i am asking dumb questions! :slight_smile:

I installed Suse 11.1 today (with the KDE gui i think its called - not gnome anyway!) and so far i think it seems great.

My main reason for installing was i was fed up with Vista and wanted a change. Everythign installed great and i then installed Wine and World of Warcraft (the main thing i use my pc for).

When i ran Wow via Wine I would get a total system power off after about 1 to 2 minutes so i spent an age trying lots of different changes one by one then relaunching it.

However, I was just on without running wine and my pc just shutoff in exactly the same way.

Is there anything I can look at here relating to this that may be the cause?

There’s no such thing as a “dumb question.” What’s “dumb” is refusing to ask. :slight_smile:

Is there anything I can look at here relating to this that may be the cause?

Three things:

  1. What precisely is happening when it goes down? Do you get any warning? I assume you mean that it’s acting like you’ve held the power switch for several seconds.

  2. Boot back into Windows and play around for awhile; see if it’s happening there. It’s possible that you have a new hardware problem that just decided to show up since you install Opensuse. (Not necessarily, but it’s worth checking.)

  3. The system logs under Linux are one of the first places you should always look. Immediately after you have a powerdown event, note the time. Boot back up. From the K-menu, open Yast (“system configuration”) -> Miscellaneous -> System Logs and look at /var/log/messages around that time. Look for an event from “acpi” or something like that.

Well I just looked through the logs and couldnt find anything that jumped out at me, so i noted the very last thing in the log and relaunched WoW which is guaranteed to power off the pc, which it did. I waited a couple mins inbetween & I then reloaded suse and checked the logs again. There seemed to be nothing in the log between where i took a note before launching wow via wine and me relogging onto Suse…

As for what the pc is doing, its as if it loses power and it just goes ‘click’ and turns off.

I dont have win installed anymore, so i cant go back to try that out.

By the way, you can also look at the system logs by using System -> File Manager (Super User Mode) and browsing into the /var/log directory that way. You can click on a log file to display it and can search for anything interesting with Edit | Find. I should’ve mentioned that.

If I read you correctly, the machine was NOT shutting off before you installed WoW and Wine, right? In that case, try uninstalling Wow and Wine. I know that’s a pain in the neck, but if the power-downs stop happening, at least you know what’s causing it. You can then attack from that angle. :slight_smile:

If uninstalling them doesn’t solve it, then something has gotten hosed in your installation.

I’m going to add something to this thread, though I’m sorry it is not too informative.

I had an issue with 11.1 on my Box. In my case it was as if someone had just flipped the power off - But in my case the bios reboots the machine. I thought it was a failing HD, it wasn’t. In fact I couldn’t pin it down. Believe me I went through the works with it - even a complete Vanilla install with only updates, test after test.

As you will from my sig. My box is now Fedora 10 - No Problems.

WEIRD. You think it might be an 11.1 issue? Maybe the OP should back off to 11.0 or 10.3, and see if that works … and if so, maybe a bug report ought to be filed.

Your guess is as good as mine and bug report is only really any use if you have something concrete to report. I have some suspicions - but that’s it. Logs revealed nothing going awol.

It’s worth trying 11.0 and see what happens. I considered it. Certainly it was rock solid - I ran it from release up to 11.1 - beautiful.

how new is the box? is it a laptop? what is its brand/model…what
kind of graphics…

i have read that Vista “poisons” some BIOSes making heat control
impossible without it…(search google with words like: YOUR
brand/model linux shutdown)

to me, it sounds like a heat problem [especially so if the box runs
and runs if just surfing the web, but 1 to 2 minutes of WoW
consistently causes a shutdown]…

comparing the SOUND of the machine with Windows and now, are they
about the same (that is, is the CPU fan running more or less now)???

have you adjusted KPowersave to give adequate cooling??

install and configure KSensors…how ARE the temps of the CPU,
motherboard, hard drives, etc??

open the box, are the CPU and graphic fans MOVING?

and clean out the junk in the CPU/GPU’s fans and heat exchangers…

if you have a cat, shave it! :wink:

if none of that helps, it could be a failing power supply…it can
also cause the machine to just “CLICK” and gone…


have fun

Ok the system is around 1.5 years old and is an Alienware Area 51 laptop. It has an Amd Turion 64 (2.4 ghz) 2 gigs of ram and a GeForce Go 7900 GS. As for noise from it, things dont SOUND bad - just a very low hum. However I’ll try installing Ksensors and see what that tells me.

MattRennie wrote:
> Ok the system is around 1.5 years old and is an Alienware Area 51
> laptop. It has an Amd Turion 64 (2.4 ghz) 2 gigs of ram and a GeForce Go
> 7900 GS. As for noise from it, things dont SOUND bad - just a very low
> hum. However I’ll try installing Ksensors and see what that tells me.

ok…it is new enough that the hardware should be ok…still, if
you have a cat (no kidding) or otherwise have used the machine in a
dusty environment there may be some blockage in the cooling system…
see: http://forum.notebookreview.com/showthread.php?t=60914

one thing to note is that most folks find the 64 bit version of
openSUSE a little more troublesome than it is worth…

MAYBE, if you have 64 installed, you might try 32 instead…

oh, and have you checked with Wine HQ to see if you have the best
setup possible?? maybe:
http://appdb.winehq.org/objectManager.php?sClass=application&iId=1922

and, you didn’t provide a model number for that Alien, so i got a
quarter million hits off of Alienware Area 51 laptop linux…if i were
you i’d do it again adding YOUR machines model number…something like:

Alienware Area 51 m5750 linux “World of Warcraft”

where i found this: “I have an alienware area 51 5750 and it seems to
be getting a little hot. I think this because of issues I am having
while playing World of Warcraft…I’m not having anyother issues with
other games, so I cant be for certain if it’s the game, graphics
card, or overheating issues.”
http://www.hardforum.com/showthread.php?t=1187789

bottom line: i do not believe there is a magic bullet for you…there
could be several ‘problems’ that you have to solve…i DOUBT any of
them are gonna be solved just by changing openSUSE settings (with the
possible exceptions of those i’ve already mentioned: 32 vs 64,
ksensors to monitor, and kpowersave setting…

good luck, and

have fun