Weird system behavior upon startup (Random issue)

Recently, upon logging on to the system, the desktop was loaded but without the dual desktop indicator right besides the openSUSE start button on the taskbar panel.

When I checked this, all of the following were the problems observed:

  1. Dual desktop indicator was not shown
  2. WIndows were loaded without the header (no application name, no close, minimize or restore buttons)
  3. Keyboard shortcuts were not working (tried WIN key to open Application launcher, CTRL+Q for closing the opened window - both didn’t work)
  4. WIFI didn’t connect. It showed some error saying “Unable to connect to the WIFI”, although everything was fine.

This issue seems to appear randomly without any particular patter. Further, when I restart the OS, it works just fine.

Recently, OS got stuck when I opened 9 windows on Steam showing information about different games. Nothing worked, no keys no clicks. So I had to hard restart the PC.

When I did that, the issue turned up again. And when I logged off from the user, it logged in automatically without prompting for password again, and showed me the previous session that was open before I hard restarted the PC.

Please help if there’s anything that can be solved here.