Weird Sound problem

>:(
Hi everyone,

I am using opensuse 11 at the moment. Sound actually works. but only in one application. Lets say if I run an avi video vlc player works fine and everything is normal.
But if I watch a youtube video after the avi or mpeg video there is no sound. and the other way around as well if i watch the flash video first in my browser it works , theres no sound from vlc or totem. and They dont at the same time as well.

I would be glad if I could find a solution here because this is very annoying.

I suspect there could be more than one problem here, and so instead of providing detailed guidance, let me provide some generalities instead.

You likely know openSUSE is delivered crippled by Novell/SuSE-GmbH for proprietary multimedia. Hence what one needs to do is replace the Novell/SuSE-GmbH packaged multimedia with functional 3rd party multimedia.

My experience is that multimedia Packaged by Packman works well. Another multimedia supplier for openSUSE is Videolan, however there is no effort made between Videolan packagers and Packman packagers to ensure their packaged applications work together. Hence IMHO since I see Packman offering a wider selection of apps, I recommend users stick with Packman and do NOT install any videolan apps (with the exception of installing libdvdcss2 from videolan).

The way I recommend to do that is to limit one’s software package manager repositories to OSS, Non-OSS, Update and Packman and add NO OTHER repositories. At least do NOT add any others until one understands the risks and the implications of having such additional repositories (ie in the example I give, videolan packaged apps are often NOT compatible with packman packaged apps - hence definitely do NOT install videlan packaged apps)

If one uses the one-click install methods, one has less insight and control into what repositories are being used. Hence I recommend one not use one-click install, if one encounters hiccups such as you note in your post.

Now by installing libffmpeg0 from packman, that application will install a bunch of dependency applications providing one most of the codecs that one needs. Using a libffmpeg0 packaged from videolan will not work with packman packaged players. Hence again, stick with packman.

One can also get various codecs from w32codec-all. There are also a handful of other specific apps for other specific codecs, that can be installed. It is helpful if one identifies the specific codec (or website) that is giving one problems, when looking for specific assistance.

When it comes to playing youtube, I use firefox with mplayerplug-in. Which means I also have MPlayer installed. In fact I use smplayer, which IMHO is currently the best multimedia for openSUSE videos. The player vlc is very good too, but the latest vlc version has a problem with mpegs and dvd playback.

Since many web sites use flash, I find installing flash-player also useful for firefox in openSUSE.

The players I use for video are smplayer, xine-ui (front end to packman packaged libxine1), vlc (but not as much due to mentioned bugs). I have no totem experience, so I can not help re: totem.

My comments are based on 32-bit openSUSE experience. Various users struggle implementing 64-bit on openSUSE, which IMHO is not as straight forward as using 32-bit.

I recommend you check which packaged versions of your media players/codecs you have installed, and then switch completely to Packman packaged versions.

Good luck, and I hope the above general words/comment help.

Another general comment, is one also need to be aware of any influencing affects from using

  • special desktop effects (ie the 3D cube … ) and
  • intel graphics hardware

Currently with openSUSE with special desktop effects enabled, one needs to switch the output video module of their media player to ‘x11’ to get video. ie often ‘xv’ (xvideo) or ‘auto’ will not work with special desktop effects. Another approach is to simply disable special desktop effects.

With intel graphic hardware, one can also have problems displaying multimedia in openSUSE. Depending on one’s openSUSE version, sometime the fix is to use a different graphic hardware driver. In other cases the solution is to use ‘x11’ as the output video module. And in other cases I have read of custom hand edits to one’s /etc/X11/xorg.conf file helping.

Specific information is needed to determine which, if ANY, of these considerations apply to a user.

thanks for the detailed reply.

Hi oldcpu,

Which repositories are you talking about when you said oss and non oss, Main repository oss/nonoss or openSUSE-11.0-oss/nonoss?

Thanks.

My understanding is they are the same (ie the URL is the same), just the label is different. So Just remove one.

Thanks, by the way my previous problem is solved after i did exactly what you said about the repositories.