Weird problem with console-kit-daemon and NetworkManger

Hi,

I have a strange problem with a laptop. After a few hours of debugging I
think the problem is that part of the DBus/PolicyKit/ConsoleKit settings
got lost or confused.
Since I got so far, I’d be interested in finding the cause and - if
possible - remedy it without re-installing the entire system. I realize
this might not be possible or worth the time, but at least I’d like to
get an understanding of the problem instead of just wiping out the system.

I have 2 problems but I think they are somehow related to eachother.

Problem 1)

What I think the main problem is that the console-kit-daemon, which is
supposedly started by DBus does not start automatically anymore. This
caused GDM not to show any users in the greeter, thus making impossible
to log in. I tried to switch to KDM which does show users, allows to log
in, but throws an error (see below) before starting a session.

Some debug info:
I get this statement from the
ConsoleKit 0.4.1 Documentation
page.

        dbus-send --system --dest=org.freedesktop.ConsoleKit \
          --type=method_call --print-reply --reply-timeout=2000 \
          /org/freedesktop/ConsoleKit/Manager \
          org.freedesktop.ConsoleKit.Manager.GetCurrentSession

When executing this immediately after boot from a (non-graphical)
console as root at runlevel 5 it produces this error message

        Error org.freedesktop.DBus.Error.Spawn.ExecFailed: Failed to execute program /lib/dbus-1/dbus-daemon-launch-helper: Success

This error message is the same what I get after a successfull login at
KDM but before the start of a session, as mentioned above.

I’m able to start console-kit-daemon manually and when re-executing the
above dbus-send command, I will get a different error message:

Error org.freedesktop.ConsoleKit.Manager.GeneralError: Unable to lookup session information for process '5008'

Which seems to be quite normal.

This is one part of the problem.

Problem 2)

The other is that NetworkManager does not work with WLAN interface,
which btw. works just fine if I disable NetworkManger
in /etc/sysconfig/network/config. So even if I start the
console-kit-daemon before logging in to GNOME, NetworkManager will not
work properly: it grays out the wireless connection with “device not
ready”

So now the part which makes me think that part of the DBus config is
gone, is that in a graphical session, the

	polkit-gnome-authorization 

program shows that in the org.freedesktop structure the entire
packagekit, network-manager-settings and consolekit subtree is missing.

I tried to trace this back to missing files or packages, but so far I
was not able to do so. Does someone knows how to these config structures
can be restored? How could they gone lost in the first place?

Btw: this system was originally an openSUSE 11.2 which I upgraded to
11.3 yesterday. Problem 1 was already there before the upgrade.

Appreciate any insights.

Regards,
Gábor