weird problem with audio

Hello everybody :slight_smile:

Recently I installed openSUSE 13.1 x86-64 everything worked fine. However today my sound has started working really strange. After booting to my system I did not hear any sound from speakers. I tried to test it several times from KDE mixer but any sound. However after plugging my headphones to computer I heard sound from them and after unplugging I hear sound from speakers as well. After rebooting the system is the same. I have to re-plug my headphone to activate sound. It is really strange. I already checked several forums, but I did not find solution for this particular problem. My sound card should Intel. Notebook I run OS on is HP probook 450 G1 and I have dual-boot system with Windows 7 ultimate. But as I said by today it did not do any problems to me.

head -n 1 /proc/asound/card0/codec*
Codec: Intel Haswell HDMI

THank you very much for your help. Martin :slight_smile:

Thank you very much. Problem is already solved. I just needed to change some settings under KDE Mixer audio setup it already works fine :wink:

Martin.