Weird pci RTL 8185L wireless behaviour

My daughter’s PC drive burned out, and I decided to “upgrade” to oS 11.1/KDE3.5, previously she was using 11.0/KDE3.5 with a wireless TP-Link tl-WN321G USB adapter with reasonable performance.

After the upgrade I couldn’t make the USB thing work (no option for WPA-PSK encryption, maybe an old or bad module), so I decided to install a brand new PCI card I got 3 months ago as a warranty replacement for a defective one. I posted about that here: wireless netgear usb wg111v2

The thing didn’t work at first, and yast network device config module gives a weird message when I tried to configure the card:

It was not possible to configure the network card because the kernel module (eth0, wlan0) is not present. This normally occurs when the firmware (for wireless devices) is missing. See dmesg output for more info.

And the EDIT button is grayed out (the above is translated from pt_BR, so it may not be 100% literal).

The weird part is, AFAICS, there’s no need to install the firmware for this, and the rtl8180 module is loaded. Some info:

# lspci |grep RTL
01:0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8185 IEEE 802.11a/b/g Wireless LAN Controller (rev 20)
# lsmod |grep rtl
rtl8180                31560  0
mac80211              241664  1 rtl8180
eeprom_93cx6            2584  1 rtl8180
cfg80211               73248  2 rtl8180,mac80211
# uname -rv #1 SMP 2010-02-22 16:49:47 +0100

iwconfig only reports lo and eth0.

OK, almost quit, then decided to reboot. Of course it worked, all normal, and I could configure the card in Yast, associate to the AP and browse the web in firefox, update some unrelated packages (desktop-texts and gwenview). After about 15 minutes of inactivity the network monitor (knetstats) panel icon show the card is disconnected, and it stayed that way. Yast network device shows the previously configured cad as inactive and a “new” card (the same) unconfigured. I deleted the inactive card and rebooted, but now yast tell me the same thing about “kernel module (eth0, wlan0) is not present”.

But dmesg gives:

ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 19
vendor=10de device=03f3
rtl8180 0000:01:0a.0: PCI INT A -> Link[LNKC] -> GSI 19 (level, low) -> IRQ 19
0000:01:0a.0 (rtl8180): Unknown RF! (0x0)
vendor=10de device=03f3
rtl8180 0000:01:0a.0: PCI INT A disabled

Could this be an IRQ assignement problem? I grepped (this verb exist?) for IRQ 19 in /var/log/boot.msg but got the same as in dmesg.

Any suggestions will be greatly appreciated.


Also, I installed these packages from /repositories/driver:/wireless/11.1-update:

# zypper se wireless
S | Nome                        | Resumo                                                          | Tipo
i | compat-wireless-kmp-default | Kernel modules for several WLAN adapters from | pacote
i | compat-wireless-scripts     | Scripts for package compat-wireless-kmp                         | pacote
i | wireless-tools              | Tools for a wireless LAN                                        | pacote

The kernel module versions (not shown above) are

The unknown RF message from your previous message is surprising. You may have a
new variant of the 8185L that needs some changes to the driver. Please run the

/sbin/lspci -nnv

and post only the section that describes the 8185.

Ha! today it wouldn’t even show in lspci. I changed the card to the other pci slot (there’s only two in this mobo) and it is working again. For now…

I suspect (but I’ve been wrong before, occasionally :D) that this is either a mobo hardware issue (defective/incompatible pci slots/implementation?) or pci/irq configuration - the mobo, a year old low-cost ASROCK N61P-S doesn’t even have any irq/pci/pnp settings in BIOS.

I think I’ll try the USB wireless dongle again, but if so I’ll post a new thread.

Here’s the info for the pci card in the new slot:

# lspci -nnv
01:08.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8185 IEEE 802.11a/b/g Wireless LAN Controller [10ec:8185] (rev 20)
        Subsystem: Realtek Semiconductor Co., Ltd. RTL-8185 IEEE 802.11a/b/g Wireless LAN Controller [10ec:8185]
        Flags: bus master, medium devsel, latency 32, IRQ 19
        I/O ports at e800 [size=256]
        Memory at dffffc00 (32-bit, non-prefetchable) [size=1]
        Capabilities: [50] Power Management version 2
        Kernel driver in use: rtl8180
        Kernel modules: rtl8180

Thank you lwfinger for your help. It’s much appreciated.[/size][/size]