Weird KDE desktop effects caused by down arrow key

I have a logitech coreless keyboard that has always “just worked” and I’ve lived without programming any keys, no factory. no tumbleweed, recent fresh re-install of 11.4, updated generally and with kde 4.6.5, xorg 7.6, nvidia driver 275.21

Mysteriously, the down arrow key no longer works as it should, (up, left, right are fine)

Rather it has the effect of crashing the transparent task manager and adjusting the focus of open windows.

If I repeatedly hit the down arrow key the focus toggles and then transparency is re-enabled.

The best way I can describe the effect is that it is as if I were using [tab] to toggle through a text based menu (e.g., YaST launch in terminal mode)

May I ask if anyone has any thoughts?

(I’ve asked on KDE forums but it occurs to me I posted in the wrong place)

Test a new user login

Does the following command solve the problem:

setxkbmap -v 10 -display $DISPLAY -geometry "pc(pc105)" -keycodes "evdev+aliases(qwerty)"

Do you have /tmp on a separate partition?
Do you see files ending with .xkm in /tmp. Example:

# find -L /tmp -name "*.xkm" 

Do have users write access to /tmp?

On 09/06/2011 06:56 PM, gerrygavigan wrote:
> May I ask if anyone has any thoughts?

you didn’t say so i assume you had the same problem when you tried that
kb on a different machine (or not)? or the kb on a different OS on the
same machine (or not)? or on a different Linux on the same machine (or
not, easily with a live CD)? or a different DE in the same system? or or
or ??

with my assumption: sounds like a hardware problem to me…that is,
hitting that one key is sending the wrong signal to the computer…

when was the last time you gave it a cola/beer or coffee bath? :slight_smile:

there are ways to see exactly what values the kb is sending, but i’d
have to look that up with google…

if you are certain it is not hardware, then try using YaST to add a new
TestUser, and log out and then back in as the Test…and, see if that
key is still ‘broken’ if it is not you know your /home is messed up…

btw, before we go further (if need be) tell us what you mean by “recent
fresh re-install” and how you did it (full format and reinstall, or
what?) and, have you made any changes to any of the settings in Personal
Settings - Configure Desktop 1) Shortcuts and Gestures; 2)
Accessibility; or 3) Input Devices? if you have, what happens if you
undo them?

finally, if you look at Personal Settings - Configure Desktop > Input
Devices > Keyboard > Keyboard model: is your specific keyboard correctly
identified by the system? if not, is your specific model listed, and
what happens if you set it?

openSUSE®, the “German Automobiles” of operating systems

Thank you for replying.

The down arrow works for a new user. (d’oh)

Inspired, I checked System Settings

> Locale and reset the language to British English but that made no difference
> Hardware Keyboard model - tried all variants of Logitech cordless

I looked in .kde4/share/config but couldn’t see an obvious file to check.

May I ask if you have any further suggestions?

Unless you feel like trolling the minefield of settings in kde and looking for something that isn’t there, because it’s actually down to some rogue gremlin that has ‘Jeffed’ your .kde4

Then I would log in like this: Login/console.login.png
Then do

mv .kde4 .kde4-old

That will rename your .kde4 to .kde4-old
So remember, some things you might want are in that renamed folder. But only bring back what you really can’t live without.

If this doesn’t resolve it for you, I’d be very surprised.

Such as the entire contents of my kmail folder… :slight_smile:

I’d considered something doing that. I’ll chew on it. Thank you again for replying

Yes, but you can bring that back from the -old folder.