Weird issue with mouse clicks over top-most pixel on screen

Since about a couple of weeks ago I started experiencing a very weird issue with mouse clicks when I try to click on the top-most pixels of the screen (y=0). Many times clicks are not registered, since the mouse hover seems to fail and the windows kind of lose focus or something similar. I’m experiencing this on my two Tumbleweed installs, with total different hardware, so it seems a software issue, I think the issue started with a Xorg update. I tried many ways to mitigate the issue with no success: tried several WM, tried running NO WM. But the issue is always present. It’s a little bit hard to explain so I recorded a video with Midori browser that makes the issue VERY visible, but sadly the issue happens with any program, it’s specially annoying with web-browsers since tab click is affected (tried Midori, Firefox, Chrome, Brave, Opera, etc, all have the same issue).
Is there anyone else experiencing this? Does anyone have any clue on what could be happening? I’m starting to get really annoyed.

Video link:

Thanks in advance.