Weird Grub


I have a weird super slow grub (slow at switching the options). It is just like refreshing a browser page with lots of heavy content after each action done in the grub menu.

I switched from Uefi to Bios Legacy boot mode on an Acer laptop and tried to install the bootloader in MBR (/dev/sda) and /dev/sda1, the same weird grub as a result.

The system language is Russian, the Grub is in Russian too. Can the language cause this issue or am I doing something wrong?

I am going to attach an image shortly.

Here it is the image.](

grub.cfg is below, hope it helps. Thank you in advance.

Hi everyone!

I have to same problem (except for the Russian characters). The bootloader is very slow and every line builds up typewriter-style. This repeats every second until the automatic 8 (veeery looong) seconds have passed. Does someone know how to fix that?


I don’t know what the problem is. I can’t see any obvious issue with the “grub.cfg”.

Maybe it is just a slow BIOS. Grub uses BIOS services for all I/O (reading disk, writing to the screen, etc).

Once opensuse is loaded, it uses its own device drivers. But grub works before that, so depends on BIOS services.

What screen resolution it selects? Try explicitly set smaller resolution.

First I tried changing to different resolutions via yast, but there was no change. Using vbeinfo in grub gave me 2560x1440 as preferred resolution, so I put the following into the grub.cfg:


But that didn’t change anything either.

Here’s my grub.cfg:

If this was preferred resolution, that was probably selected by GRUB already. I suggested to try smaller resolution to see if it will make GRUB more responsive.

As I said I tried different resolutions via yast and to be sure also by manually changing the grub.cfg. There should actually be no difference between these two methods, right? However, no difference in my grub’s appearance and behavior. Could it have to do with my graphics card/drivers? I’m using a Lenovo Thinkpad T460p with Intel HD 530 and dedicated Nvidia graphics.

Another question. Is the background (HidDeNeR posted the picture) the standard OpenSuse grub background?

I have the same problem and as I can see, it is specific to opensuse. I have two root partitions, one Fedora 25 and one OS Tumbleweed. which I installed later. The Fedora installation of grub2 into the MBR showed none of this quirky behaviour. This only turned up when I installed Tumbleweed and let it grub2 reside in the MBR.

Highly annoying. Only solution I can think of is to go back to Fedora and use its version of grub and adapt the necessary OS entries.

Not a solution, but for me acceptable workaround is to turn of the graphical menu in the boot loader settings.