Weird graphics glitch after second boot!

Hi there, I’m on 12.2 64bit on a laptop machine With an old Core2Duo, 4GB of RAM and an nvidia gf9300m graphics Card. After installing OpenSUSE completely from the scratch, the first boot works just fine (first the configuration window pops up, then the normal kde desktop). After rebooting with the installation USB Drive removed I get these really weird glitches which my look like a defective graphics card, but let me stress that this issue only occurs on OpenSUSE, Windows Vista worked just fine.
I have experience working with linux, but this is the first time for me using OpenSUSE/KDE.
I’ve tried several reinstalls, please help me! (It always occurs from the second boot)

Pic of the glitches:

Boot in recovery mode and update your kernel. It should fix it. In command line “zypper patch” go get latest updates including kernel. Installing proprietary nVidia drivers should also help, but I had quite a lot of problems with 304.43 from current repository, and am currently testing 304.60 to see whether it fixed those problems. So I hesitate to recommend it.

Thanks, that did the trick!