Weird graphic behavior after upgrade

I just upgraded to openSUSE 12.1 and now I’m getting a weird behavior with my graphics.

First of all, xorg is constantly over 10% of CPU usage, and sometimes it goes to the roof and the computer freezes for entire minutes. I’ve changed from openGL to Xrenderer but it still happens, and I don’t know the cause since it seemed to work fine with 11.4

Apart from that, I’m getting weird behavior with menus. When a menu is loading (either kick off, right clicking or chrome’s old pages visited menu that appears when I start writing in the url bar) it shows like a black rectangle. When it finishes loading (less than a second after that), it renders normally. Also, when I open konsole, the opposite happens, I get a white background for a second, then it loads into its black form.

Lastly, after sometime (or event I don’t know), in Chrome I highlight text but the highlighter is white instead of blue (which means it creates a white rectangle, because the text gets white when highlighted), that behavior doesn’t disappear until I restart Chrome.

Being all graphical problems, I suppose they’re related… I’m still a little n00b in this GNU/Linux thing, so please forgive me for anything that I missed explaining/explained wrong.

Can you tell us a little more about your graphics chipset? That will help others assist.

/sbin/lspci -nnk

Find the entries concerning your graphics and post here. (Please enclose the output between CODE tags for easier reading).

00:02.0 VGA compatible controller [0300]: Intel Corporation 4 Series Chipset Integrated Graphics Controller [8086:2e32] (rev 03)
        Subsystem: Giga-byte Technology Device [1458:d000]
        Kernel driver in use: i915

I’m also getting massive graphics corruption in 12.1 under xfce+compiz.
I’ve tried both open source and AMD Catalyst 11.11 drivers - both have huge issues.
My GPU is HD5670 and it worked flawlessly under 11.4 using both drivers.
Parts of the screen are not refreshed, compiz crashes constantly to the point of being unusable., and some other issues too.
Sometimes desktop disappears and I only see green suse background, or random data is visible for a moment

Similar with me. After updating from 11.4 to 12.1 I get weird graphic behavior with menus exactly like described on the first post; menus appear as black rectangles for milliseconds just before loading normally. I had a few crashes too causing the whole plasma desktop to disappear leaving just a black screen, while trying to experiment with the desktop effect settings. Changing from OpenGL to Xrender or disabling desktop effects completely doesn’t seem to affect or remove this problem, though.

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 09)
        Subsystem: Fujitsu Technology Solutions Device [1734:113f]
        Kernel driver in use: i915

I am using the mesa driver and everything worked just fine before updating to 12.1

I also have this problem. On 11.4 everything was running fine, since upgrading to 12.1, I see the garbled screen when I start up Opera, or use the QuickAccess widget… Using the command from above I get the following;

 01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Mobility Radeon HD 3400 Series [1002:95c4]
        Subsystem: Lenovo Device [17aa:210e]
         Kernel driver in use: fglrx_pci

I have also changed from OpenGL to Xrender, with no difference in behaviour. Xorg goes up to 10% even when minimising and maximising Opera

OpenSuse 12.1, Lenovo T400.

I have the same problems after upgrading to 12.1 and also had no problems before with 11.4. Additionally I can’t enable direct rendering with latest fglrx driver, I tried with latest version on ati repo (Index of /mirror/ati/openSUSE_12.1) and with latest from the official website, but in both cases direct rendering didn’t work. Fglrx driver is installed successfully, catalyst control center works perfectly, exept direct rendering.

For me this is the reason why all my games crash in wine, and this may be the reason for this “weird graphic behavior”. Any ideas how to fix this problems?

I’m using openSUSE 12.1 standart repos + KDE 4.7.2 (Index of /repositories/KDE:/Distro:/Stable/openSUSE_12.1) with this driver - fglrx64_xpic_SUSE121-8.902-1.x86_64. My graphics card is ati mobility radeon hd 4570 (M92) on acer aspire 5536g laptop.

client glx vendor string: Mesa Project and SGI
client glx version string: 1.4

OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon HD 4500 Series
OpenGL version string: 1.4 (2.1 (3.3.11161 Compatibility Profile Context))

direct rendering: No
*** WARNING: Direct Rendering is NOT enabled

I have the same problem, direct rendering are not. I have catalyst and works, but transparencies no are right.

with xorg-server 1.10 the system are very slow, if i downgrade to xorg-server 1.09 the performance are good.

In Debian Wheezey seems dont have problems, but they have xorg-server 1.11.

How could be update my xorg-server in openSUSE 12.1?

-I haven’t had any more semi-freezes, but xorg is still always at least at 10%

-The kickoff menu sometimes doesn’t show some categories’ icons. Screenshot available:

-My scroll bars in chrome appear black sometimes (i.e. some other times they’re the default grayish color). Screenshot available:

Anything you may want me to try I’m willing to do it.

Thanks in advance!

You upgraded to 12.1 from a previous version right? You problems might be related to KDE config files that are not entirely compatible with new version. (It could be related to the desktop theme you were using for example). There are a couple of approaches to tracking these down.

1: Create a new user and observer whether this desktop mis-behaviour still exsists.
2. You could make a copy of ~/.kde/share/config/, and delete the original, then restart the desktop with CTRL-ALT-DEL twice. (This will return the desktop to default settings).

Sorry, it didn’t work x.x

Same here. Created a new user and tried it out. I still had the same issue.

I don’t know if this could help, but I just noticed the highlight doesn’t become black. It becomes the same color as the background is. The highlighted text does too, so it seems to disappear. I can post a screenshot if needed. I want to try to change drivers, but I don’t even know which one I’m using, much less how to change it u_u"

Good News.

After of probe and probe methods, i have a solution (medium right).

You can update xorg-x11-server to 1.11 (with xorg-x11-driver-video and xorg-x11-driver-video to compatible versions) and downgrade Mesa to 7.10.2; with this the performance are good, transparencies and effects too.

I still with out direct rendering, but this its my greater contribution.

I was able to turn on direct rendering by removing completely fglrx and /etc/ati folder plus all old xorg conf files and adding new one with radeonhd driver enabled. Then I rebooted the system ones and direct rendering with open source drivers works, but performance still wasn’t good, but after that I was able to install manually ati catalyst 11.11 drivers from amd’s site and now catalyst works with direct rendering on and overall performance is good.

My xorg-x11-server version is 7.6_1.10.4-36.2.1 and Mesa is 7.11-11.1.2 but I removed completely all xord configuration files before been able to install working fglrx driver, before that reinstalling the driver didn’t work for me.

I’m thinking on making a fresh install… this is starting to get really stressing. As I don’t care much anymore about breaking the system, can anyone give me a tutorial on how to change my video drivers? Thanks in advance :3

From a practical theory point of view, there is this old guide: openSUSE Graphic Card Practical Theory Guide for Users … It is up to date as of openSUSE-11.4, and while I still need to review it after I get some 12.1 experience, I think it still relevant. I don’t mention sax3 in it yet, as sax3 is still under development and not complete as a tool.

I note your 1458:d000 means a Gigabyte GA-7VM400(A)M(F) Motherboard (or an M400 without the ’ (A) ’ ) and the 8086:2e32 means an Eaglelake Integrated Graphics Controller (GMA X4500 - Integrated in an IntelG41 Express Chipset). That explains the Intel driver being used.

With Intel hardware, your choice for drivers is pretty much limited to (1) fbdev (poor performance) (2) vesa (slightly better but still poor performance), (3) intellegacy (an old version of the Intel driver) (4) intel (the latest driver version packaged by openSUSE). It is possible to install even newer versions of the Intel driver, but since I don’t have a PC to play with that supports new Intel hardware that needs such a cutting edge version, I have not written a guide for that (nor do I feel comfortable doing such without experience).

Good luck.

The “new user” solution didn’t work for me out either. I am sure it is not because of the old user settings; the same problem appears on my hardware even when running openSUSE 12.1 from the KDE live CD.

In my case the problems where solved when I downgraded xorg-x11-driver-input, xorg-x11-driver-video and xorg-x11-server to the versions from the openSUSE 11.4 repository (Index of /distribution/11.4/repo/oss/suse). I kept the xorg-x11-driver-intel-legacy to the 12.1 rep. version. My guess is that it could be a bug with the new xorg video drivers for this Intel Graphic Chip.

Any progress on fixing this error?

I’m using Ati Catalyst 11.11 with Sebastian’s Siebert install script, DRI works (xvba doesn’t though) but still I’ve got graphics corruption under xfce (both xfwm4 and compiz).
This is the only thing that prevents me from using 12.1 now, all other issues solved.

I’ve tried to install xorg from both 12.1 and 11.4 repos (x11/xorg) and Kernel 3.1.4 - no luck.

sobrus wrote:

> Any progress on fixing this error?
> I’m using Ati Catalyst 11.11 with Sebastian’s Siebert install script,
> DRI works (xvba doesn’t though) but still I’ve got graphics corruption
> under xfce (both xfwm4 and compiz).
> This is the only thing that prevents me from using 12.1 now, all other
> issues solved.
> I’ve tried to install xorg from both 12.1 and 11.4 repos (x11/xorg) and
> Kernel 3.1.4 - no luck.
On desktop with openSUSE 12.1, I downgraded xorg-x11-server, xorg-x11-
driver-video, xorg-x11-driver-input packages to version shipped with
openSUSE 11.4. Then I installed fglrx (currently 11.12) and now I’m happy
with it.

With laptop (intel + ati HD) I have no luck. Even fglrx 11.12 doesn’t work.
X crashes while trying to start:

60.104] 0: X (xorg_backtrace+0x37) [0x80a86b7]
60.104] 1: X (0x8048000+0x64a0a) [0x80aca0a]
60.104] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xffffe40c]
60.105] 3: /usr/lib/xorg/modules/drivers/

(xdl_xs110_atiddxPxPreInit+0x139) [0xb6818129]
60.105] 4: /usr/lib/xorg/modules/drivers/
(xdl_xs110_atiddxPreInit+0x23d4) [0xb67e99e4]
60.105] 5: X (InitOutput+0x853) [0x80bd5d3]
60.105] Segmentation fault at address 0x8
Fatal server error:
60.105] Caught signal 11 (Segmentation fault). Server aborting

Now I’m building kernel for openSUSE 12.1 to test it on this laptop
with fglrx. For test purpose I installed frugalware with kernel 2.6.39 and
xserver 1.10.3 - and with this setup fglrx 11.12 works fine.

Pozdrawiam / Greetings,
Mariusz Fik
openSUSE Community Member
openSUSE 12.1 Rocks!