Weird destop/compositing problem

I tried setting my 11.1 x86_64 desktop to Folder View and it crashed a couple of times. When I reverted it, suddenly I have the Compiz desktop cube - and I can’t disable it. The desktop cube is really just one big desktop and I can’t switch VirtualBox correctly so I’d like to turn it off (so Ctrl Fx switches desktops).

Any ideas?


EDIT: I tried compizconfig-settings-manager and Configure Desktop…

So you are using compiz rather than kwin?

I guess - how do I fix? Can’t figure the procedure out in KDE4…

System settings > Desktop

In there disable desktop Effects

If that isn’t sufficient go to
System Settings > Default Applications > Window Manager = Use KDE Default
Logout and back in

If necessary check this agai:
System settings > Desktop

In there disable desktop Effects

Thanks - don’t know what “System settings” is - is that in YaST somewhere? Or in Configure Desktop? I looked in YaST and couldn’t find it.
(I’m always carping how I can’t find anything in KDE4 - years of learning KDE flew out the windo)

Hi Patti

Yes, Configure Desktop (= System Settings). Its a KDE desktop configuration, hence not in YaST. Follow the directions given by Carl. :slight_smile:

Hah! I thought I had searched through Desktop Settings… alas! But all is well now.

Good. I disable effects most of the time too. Just use it to show off to mates…

Thanks for your help - I tried turning off effects but they wouldn’t stop - but I didn’t know I had to turn off compiz. I guess there were “issues” with 11.1. I wish I could move up - but my ProBook 4510s has problems with the installers in 11.2 and, so far, in 11.3 RC2. Weird, considering the ProBooks optionally come with Novell SuSE on them. (one of the reasons I bought the ProBook)

Please post result of this

/sbin/lspci -nnk
I can see your hardware

From googling I’ve seen that the HP 4510s has problems with recent Linux distro installs. (It uses the Intel 4500HD chipset).

I have seen suggestions that kernel mode setting issues exist with regards to the Intel drivers and specific hardware configurations. The workaround is apparently to use ‘nomodeset’ boot option, although some users still find problems even with this. I guess you could also try a text mode install and configure the graphics post install.