Weird clicking issue in firefox-flash

There is a strange problem with the flash plugin. In many websites that use flash (that were 100% fine when using other distros) clicking on anything in the flash player doesn’t work (if you need examples: City of Reality » Archive » 05 033 TheGame 648 1200 and Bloxorz - Free Online Games and Free Puzzle Games from ).
The objects seem to not be detecting my clicks at all.
On other websites (like youtube) clicking seems to be fine: I can pause and start the video perfectly well.

I can get over the first issue by telling firefox to use gnash, but then youtube videos don’t play at all.

Does anyone know what the issue with flash might be?

Version numbers:
OpenSUSE: 11.2
Firefox: 3.5.4
Flash plugin: 10.0 r32 (according to about:plugins)

My guess: 64bit system?

If so, uninstall flash-player through the software installer, install flash-player-64bit through , search for ‘flash-player’ and do a one click install from a repo that contains the x86_64 version.

No, it’s just a regular 32-bit system… Sorry, I didn’t think to mention that.

I had a similar problem trying to start embedded youtube videos. I was running compiz when it was happening and have since stopped and it seemed to get better.

Nope, returning to metacity changes nothing.

To be honest, I don’t think I’ll stick with opensuse. I’m not saying this to start a flame war or anything (and I really hope that’s not the result!) but I’ve tried several distros lately and they all worked fine… except this one (this isn’t the only “big” problem I’ve had).

Still, maybe finding a solution will be useful to other people having the same problem in the future and finding this thread.
Thanks for your time anyway :slight_smile:

I have opensuse 11.2 and finally thanks at this post, my flash works again…BUT I find its veeery slow the reproduction. Consumes so much CPU i think, if anybody find a solution… plz post

It’s caused by nspluginwrapper which on a 32bit system you really don’t need IMHO.

Uninstall and lock it (zypper al nspluginwrapper) and all should be well.