Weird boot incident.


I have an intel NUC and decided to try the usb stick and LEAP 15 for a hardware install.
That worked perfectly.
Then, I wanted to install Fedora 28 in a dual-boot.
That worked, but I couldn’t boot LEAP (a menu item) anymore, a message said that the kernel wasn’t loaded. Strange, because grub pointed to the right partition.
But, I still had the usb for Leap 15 so I could go to the resue system. The choises weren’t very clear so I went back again and asked now to boot from the hard disk, fully expecting to see Fedora again and inspect some files in /boot.
Wrong, it started openSUSE.
Of course, I used Yast to rebuild my Boot Loader and now it works as expected: openSUSE is now first and Fedora also boots.
But I wonder what went wrong and I guess that the installer from Fedora made a mistake that was hard to correct because they want to be so user-friendly that a user has hardly any input anymore.
Come to think of it, I had no options in Yast and the repair of the Boot Loader, either.
But that went well, so I’m not complaining. :wink:

Is this UEFI booting?

I ask, because the only time I see that message about kernel, is with UEFI booting.

The Fedora shim contains the key to verify the fedora signature. But it cannot verify the openSUSE signature.
The openSUSE shim contains the key to verify the openSUSE signature, but I doubt that it can verify the Fedora signature – unless your Fedora install added that key as a MoK (machine owner key).

Disabling secure-boot might be the easiest way to “solve” that problem.

Yes, it is UEFI booting and I admit that I don’t know much about it - save for this experience. But I didn’t add a key as MoK and afterwards, both boot normally. So its possible the Fedora install performed the action of adding a key, but then the question is: why didn’t openSUSE do likewise?

Do you mind providing the model number on the Intel NUC? I am looking at the one listed below, and would be interested on which one you were successful on.

Mine is NUC7i5BNH like

Thank you :slight_smile: