weird behavior systemd on usb drive 1 tb

Tumbleweed with this morning upgrades.

in fstab /dev/sdc2 /usr/local ext4 acl 1 2

if the drive is not connected/has no power at boot time

there is a job /service from sytemd : a start job is running for dev-sdc2.device then a counter ( for max 1 min 30 sec)

and booting is stopped for that time
do i powerup the drive when that counter is running booting continues from that moment

when i power the drive before booting the computer all goes normal no counters for this drive

how to change that so i can plugin the drive when ever i need it

Easiest would be to remove (or comment out) that “fstab” line. But then the disk will be mounted at a different location.

Another possibility is to put “nofail” into the options on that “fstab” line. (Change “acl” to “acl,nofail”).