Weird behavior in OS11 install

The bootloader portion of the OpenSuSE 11 install says:

“The boot partition is of type NFS. Bootloader cannot be installed.”

Also, it “sees” or suggests (?) RAID partitions. I have never, ever created a RAID partition on either of my HDs, nor did I ask OpenSuSE do do so. What’s going on? Thanks.

Do you have Windows? I think the error message indicates that grub has been configured to be installed in a Windows ntfs partition.

Are you wanting grub (the Linux bootloader) to control all the booting on your system? If so, go into the installation boot configuration dialog and under the Boot Load Installation tab, make sure the MBR box is checked.

Oops, got cut off editing . . . if you don’t want grub in the MBR, then install the boot loader in the root partition (or boot partition, if you have a separate one), and you’ll need to setup the Windows boot loader to chain to grub.

Mingus - thanks. Here’s the whole story (I’ll paste here the version I’m putting on the SuSE, PCLinuxOS, and Acronis Backup forums):

I installed two new hard drives recently. I mirrored my C: WinXP drive using Acronis True Image 10 to an external USB backup HD, then restored the external image from the backup drive to the new drive installed in the second HD position (drive D).

Everything appeared to work flawlessly - I was able to move the mirrored drive physically to the drive C: bracket and boot and work normally.

However, now, when I try to install Linux in a separate partition, there are problems.

Only one Linux distribution, PCLinuxOS Minime 2008, installs without errors. But three others - PCLinuxOS 2007, OpenSuSE 11, and SuSE Linux Enterprise Desktop SP1 - cannot install the GRUB boot loader.

The message that the SuSE distros give is: “The boot partition is of type NFS. Boot loader cannot be installed.” PCLinuxOS simply says it can’t install the boot loader.

I notice during the partition section of the SuSE distros that they both find a partition called: /dev/mapper/pdc_ccfjihjhci.

I am wondering if that is a relic of the Adonis True Image mirroring process. Both SuSE distros see my C: drive as RAID and suggest RAID partitioning. Also, the PCLinux 2007 distro cannot see my C: drive - it only identifies my D: drive (as hdd).

I have never partitioned that C: drive as RAID at any time - so again, I’m wondering if SuSE is seeing the /dev/mapper partition as RAID?

Naturally, I’m wondering if it will be possible to delete the /dev/mapper partition and ensure that Linux distros can see the C: boot partition as something normal. And I really need to be able to do this without reinstalling Windows, because I have a ton of software installed, which I use in my work, and it would take a day to reinstall it all and get things back to normal.

Can you help? Thanks!

I found the solution - OS 11 now installs just fine. Here’s the link, for those who may have similar “/dev/mirror/…” mystifications on their hard drives:


Deleted, not necessary per above post.

Hi Mingus - I see you deleted your last post because the problem has been fixed. Just wanted to let you know how grateful I am that you took the time to help.

In their short life, those two new HDs have had some adventures - an install from a Windows XP mirrored C: disk, and install/uninstalls of PC-BSD, various attempts at installing OS 11, SLED 10.1, PCLOS Minime 2008, PCLOS 2007. No wonder there was crud in the boot sector. I still don’t know if it came from the Acronis True Image mirroring software or from PC-BSD - probably one of those. But the dmraid program (see link in my last post) solved it beautifully. Thanks again. - George

You’re quite welcome, thx for the thought.

The mystery device label reminds that vendors use the partition table for various purposes, often not friendly (ref: Microsoft). Glad you got it solved.