Weird ALSA problem (Dell 1535/Intel HDA)

So I upgraded the kernel and I think that’s what killed my sound…(everything is installed, and the card is configured/shows up in lsmod, etc, etc…)

I took a look, and one of the main suggestions is to upgrade to ALSA 1.20…

SO I did through YaST, but something seems not to be taking:

wing-ix:/ # rpm -qa | grep alsa


wing-ix:/ # cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.17.

I also get the 1.0.17 when I run

Something seems not quite right here… I even removed alsa completely from the system, reboot, reinstall, reboot, and got the same information… needless to say, I’ve still got no sound either…

Happened to me also tonight… No more sound.
I will try tommorow with new kernel, 2.6.30.

I have asus Pro50, HDA SIS966, intel driver.

Unfortunately, it is a weakness of all Linux distributions that updates to the kernel will often break one’s graphics, wireless, webcam, virtual-software, and sound.

nitehawk337, from script link in your post I note this:

!!Kernel Information

Kernel release:
Operating System:  GNU/Linux
Architecture:      x86_64
Processor:         x86_64
SMP Enabled:       Yes

!!ALSA Version

Driver version:     1.0.17
Library version:    1.0.20
Utilities version:  1.0.20

ie you have updated to the kernel. Unfortunately there are no packaged alsa versions yet that are specific to the kernel. The 1.0.17 alsa driver that the script is showing installed is the version of alsa that is hard-coded/packaged in the 2.6.27.x kernel. Hence it shows your PC has fallen back to using that driver version because it could not interface to the 1.0.20 alsa driver you had (which was packaged for the kernel), and hence it it is ignoring the 1.0.20 alsa driver rpm that you have installed.

Typically within a few days to a week, the SuSE-GmbH packager will package a new alsa version for the new kernels. That has not happened yet but I note Thursday was a holiday this week in Germany, and many people took the entire week off. Hence if the past is a guide, it may not be until mid-next week that we see an update to alsa that you will be able to install to fix your sound.

The only other alternatives are to:

  • custom compile your alsa driver (one needs to be an experienced average user, or an advanced user to do that) or
  • roll back one’s PC to the last functioning kernel (which assumes one kept a copy of the kernel rpms on one’s PC, which most users to not bother to do);

My recommendation, for the time being, is to wait until next week.

I have a Dell Studio 1537 laptop, and I am going on vacation in 4 days. Hence knowing of the risk of the new kernel breaking my Dell’s audio, I simply did not accept the update. I’ll wait until I return back from vacation in a month.


I believe this also explains the behavior of my
Latitude 6500: no sound since I did the update.
Also experiencing problems with another sound chipset machine machine (CK804 AC97), which was ok before …


Reference custom compiling, if one already has the latest 1.0.20 alsa rpms from the multimedia repos installed Index of /repositories/multimedia:/audio/openSUSE_11.1 then one way to custom compile (assume one also has the latest kernel-source and kernel-syms installed) may be to download the src (source) file from here:
Index of /repositories/multimedia:/audio:/KMP/openSUSE_11.1_Update/src

and then with root permissions rebuild with:

rpmbuild --rebuild alsa-driver-kmp- 

I confess I’ve never tried that myself, but it may be worth a shot. If that completes successfully, one then has to go in to the /usr/src/packages/RPMS directory for one’s architecture, and find the rpms, and then install the appropriate alsa-driver-kmp rpm. Restart and test. Again, I’ve never done this, but if I was really desperate, and if I did not want to roll back (say if I knew a roll back would not work) then I would try it.

The SuSE-GmbH packager has now released the rpms for the update to 1.0.20 of alsa for the kernel. Note this is on a special multimedia repository and not on the standard “update” repository.

There is guidance here for doing the update:
Alsa-update - openSUSE

Note one MUST send six zypper commands, being certain to pick the one’s specific to one’s openSUSE version. I recommend one optimize the alsa apps to be installed to match what one has on one’s PC already. … and also the second last command in the 3 command group should be specific to one’s kernel. Do NOT install multiple alsa-driver-kmp-<packages> … Only install the ONE that is applicable.

Further to this, I updated my kernel on my Dell Studio 1537 laptop (very similar to your Dell 1535) from the kernel to the latest kernel. As anticipated this broke the sound on the laptop, just like your sound was broken. But earlier (prior to the kernel update) I checked and I noted that the SuSE-GmbH alsa packager (who is also an alsa developer) had been good enough to package, on the weekend ( ! ) some updates to alsa, with a 1.0.20 version of alsa packaged for the latest kernel. So that packaging of his (with an updated alsa version for the kernel) gave me the confidence to proceed.

So I installed the alsa updates to 1.0.20 (for the kernel) per this guide: Alsa-update - openSUSE (note I sent 6 zypper commands to do this update) , and then rebooted, opened my mixer and ensured the “speaker volume” was up (it was at zero muting the start up sound) and sound once again worked. :slight_smile:

The same should work for your Dell sound.

I have not yet checked the mic (I’ll do this later).

Please post if you have problems.

Also, please note I am going on vacation to a different continent in a couple of days and it will be difficult for me to help after that. Maybe someone else who has been following this will be able to chime in and help in that case.

Good luck !

Hey - that is pretty cool that he updated it so quickly.

Of course, I can also confirm that just building ALSA-driver from source worked fine as well (what can I say, I’m impatient)

Neat! What method did you use to build them?

Did you try the

rpmbuild --rebuild alsa-driver-kmp-

or did you use another method?

Actually, I used the standard, ./configure method, however I did cheat a little :slight_smile:
In the interest of helping others, I’ll be a bit verbose below:

What I did was use YaST to install the 1.0.20 files (except alsa-driver-1.0.20)

Then downloaded the alsa-driver-1.0.20 from
Untared, and ran the standare configure/make. I used make install-modules, as the system already has an alsa init script from the previous versions of alsa.

#make && make install-modules

As recommended in the INSTALL file, I skipped running the ./snddevices script (as they were already there from the previous version of alsa)

I then ran


to automatically edit the kernel modules file

rebooted and I was up and running.

I had meant to try rebuilding the rpms, but in all the years I’ve been using linux, I never got a good feel for working with them, and was a bit gunshy… :slight_smile:

Thanks for sharing that!