Website access problems

This is only an issue with accessing websites. There are no issues with other Internet access. After installing openSUSE Leap 15.5 I’ve had problems accessing quite a few websites on the Internet. I can access some websites. The browsers do not complain about certificates. I thought the problem with the Internet that was mentioned weeks ago was still an issue. I tried different browsers but got the same result. Generally if I am able to access a website, then I continue to be able to access that site. If I can’t access a site, then I continue to not be able to access that site. Finally, I discovered that when I switched back to Leap 15.4, the websites I couldn’t access from Leap 15.5, I could access from Leap 15.4.

To be clear, both versions are installed on the same hardware.

Anyone else having similar issues?

If someone wants to ask how I know a website can’t be accessed, here is what the browser shows me when I try to access a website which can’t be accessed:

how the Firefox browser shows me that I can’t access a Website

A recent thread that may be of interest to you

Thanks for the thought. However, I removed the nscd package from Leap 15.5, rebooted. Tried to access
various websites. No change.

You need to describe your network environment in further detail. Are you using a proxy server? Is it just name resolution in the browser of choice or is it system-wide?

For a better picture please show the results from these commands to start with…

cat /etc/resolv.conf

You referenced in your first post. FWIW, there have been recent outages reported with respect to that domain…

Hy John, I had a problem started in Leap 15.4 and followed in 15.5, where some wallpaper provider where not recheable.
What I did, after some suggestions, was to completely disable the IPV6 configuration in the network interface.
Since then everything worked smooth.
Give it a try and check if it works for you.

1 Like

Hi Folks!

My goal in starting the thread was to find out if a whole bunch of folks where having the same type of problem I was, while using Leap 15.5. If a bunch of people were having a similar problem, then I would expect there might a problem with Leap 15.5 itself. If it was just me, then I might have made a mistake installing/configuring Leap 15.5.

As it turned out, I made the mistake, which has now been fixed.

To everyone who shared their thoughts, thank you very much!

If the “/etc/nsswitch.conf” file brings the line “hosts:” to the view and reboot the OS?

> sudo cat /etc/nsswitch.conf | grep -i hosts
> # hosts:  	files mdns_minimal [NOTFOUND=return] dns
> hosts:  	files dns myhostname


I had mentioned that the problem about which I was concerned has been solved. If you are suggesting that I make a change to the /etc/nsswitch.conf file, I didn’t make that change when using Leap 15.4 and there were no problems accessing websites.

Even so, thanks for your thought.