Webkit2gtk update

I have two updates in Discover which will not go away. They both gives a similar message:

installed WebKit2GTK-4.1-lang-2.38.6-150400.4.42.4.noarch requires ‘WebKit2GTK-4.1 = 2.38.6’, but this requirement cannot be provided

I think a new patch was installed a week ago, but the two former updates is still asking to be installed. What is this about? Are the packages WebKitGTK-4.0-lang and WebKit2GTK-4.1-lang up to date? If they are, why does the machine pushing me to update them? I tried to update in the terminal, but the updates does not appear when I do zypper update.

Dag R

delete it.

1 Like

Well, zypper is the native openSUSE tool (together with YaST > Software). I do believe it.

Delete the updates in Discover?

Post as root:
zypper up

Surprise - the fix was not complete. For 15.4 it is tracked in 1214093 – openSUSE-SLE-15.4-2023-3233 fails to install due to missing libwebkit2gtk3 = 2.40.5, interested parties may search for similar bug report for 15.5 or submit one.

1 Like

I tried both zypper up and delete them in Discover, but they still pops up.

Post as root executetd:
zypper up

As you answer me - I am not sure what you mean. Show full output of

zypper patch

udo zypper patch
[sudo] passord for root:
Laster pakkebrønndata…
Leser installerte pakker…
Kontrollerer pakkeavhengigheter…

Problem: the installed WebKit2GTK-4.1-lang-2.38.6-150400.4.42.4.noarch requires ‘WebKit2GTK-4.1 = 2.38.6’, but this requirement cannot be provided
uinstallerbare nødvendige pakker: libwebkit2gtk-4_1-0-2.38.6-150400.4.39.1.x86_64[repo-oss]
Løsning 1: Følgende handlinger vil bli utført:
do not install patch:openSUSE-SLE-15.5-2023-3419-1.noarch
do not install patch:openSUSE-SLE-15.5-2023-3556-1.noarch
Løsning 2: deinstallation of WebKit2GTK-4.1-lang-2.38.6-150400.4.42.4.noarch
Løsning 3: ignorer noen avhengigheter selv om WebKit2GTK-4.1-lang-2.38.6-150400.4.42.4.noarch ikke vil fungere

Velg løsningen over med nummeret eller avbryt [1/2/3/c/d/?] (c):

Two technical hints for using the forums:

  1. Please use the Preformatted text button from the editor toolbar. Select the copied/pasted text and click the </>

  2. When you have a non-English system, to create text for this English part of the forum, precede your command with LANG=C, e.g. LANG=C zypper patch.

Løsning 2: deinstallation of WebKit2GTK-4.1-lang-2.38.6-150400.4.42.4.noarch

It worked. The updates are gone now. Thanx!

1 Like

Hello, I’m getting the same problem I think , x2, see YAST conflict list below.
I only use OpenSuse in English, am I safe to uninstall WebKit2GTK-4.1-lang-2.38.6-150400.4.42.4.noarch

#### YaST2 conflicts list - generated 2023-09-16 18:25:41 ####

the installed WebKit2GTK-4.1-lang-2.38.6-150400.4.42.4.noarch requires 'WebKit2GTK-4.1 = 2.38.6', but this requirement cannot be provided
not installable providers: libwebkit2gtk-4_1-0-2.36.3-150400.4.3.1.x86_64[https-download.opensuse.org-bbc49379]
    [ ] deinstallation of WebKit2GTK-4.1-lang-2.38.6-150400.4.42.4.noarch

    [ ] Following actions will be done:
do not install patch:openSUSE-SLE-15.4-2023-3419-1.noarch
do not install patch:openSUSE-SLE-15.4-2023-3556-1.noarch
    [ ] break WebKit2GTK-4.1-lang-2.38.6-150400.4.42.4.noarch by ignoring some of its dependencies

#### YaST2 conflicts list END ###

Please always include the command in your copy/paste. It is only one line more at the begin (and when you want to do still better, also include one line more at the bottom, the one with the new prompt).

Not very difficult to do and then we know what you did to create the output you want to show.

This one…

I answer my own post.

I did miss that you dis not use zypper, but YaST. But we still do not know what exact action you did with YaST.

In any case, when you thought you had the same problem, then why didn’t you do the same as the OP was advised (and that helped him):

zypper patch

Thanks very much for confirming that Sauerland. It’s gone away!

PS hcvv you are right there in your reply.
I just wanted to double check as “delete it” was not super clear to me. I don’t like uninstalling things when I don’t know what they do.

Nice it is all solved. Enjoy.

1 Like