WebHTTrack/HTTrack rpm for openSUSE 11.3 or 11.4 needed. Please Help.

Hello, I am looking for anyone who might be having the rpm package for WebHTTrack or HTTrack. These packages used to be available in the openSUSE additional repos (Contrib or packman not sure which one) but now seemed to have completely disappeared from the Internet.

I did however manage to download the “httrack-3.44.1.tar.gz” package for Linux from HTTrack Website Copier - Offline Browser and install it successfully. The problem is that I think that it requires some extra configuration to work that was not documented. I got some errors on my browser when I tried to run the application.

Here is a little info on HTTrack for those who may not be familiar with it.

HTTrack is a free and easy-to-use offline browser utility. It allows you to download a World Wide Web site from the Internet to a local directory, building recursively all directories, getting HTML, images, and other files from the server to your computer. HTTrack arranges the original site’s relative link-structure. Simply open a page of the “mirrored” website in your browser, and you can browse the site from link to link, as if you were viewing it online.”

I am an university student and I absolutely need this software utility to reap web pages that have lengthy online tutorials or articles.

The error I was trying to describe earlier on the post is Server not found in Firefox. My host name is linux.site, so at the address bar for Firefox it reads http://linux.site:8080 and the “Server not found error” appears below.

When I run webhttrack from command prompt this is what I get:

/usr/local/bin/webhttrack(29913): launching /usr/bin/firefox
/usr/local/bin/webhttrack(29913): waiting for browser to terminate.

I get the same error just if I had launched straight from the menu. When I go back to the terminal and press Ctrl+C, I get the following:

**/usr/local/bin/webhttrack(29913): nasty signal caught, cleaning up…
/usr/local/bin/webhttrack: line 167: 29930 Killed ${BINPATH}/htsserver “${DISTPATH}/” path “${HOME}/websites” lang “${LANGN}” $@
/usr/local/bin/webhttrack(29913): …done
I don’t know what the problem may be.

My system is:

  • openSUSE 11.3

  • Gnome 2.32

  • Firefox 4 final.

When the rpm package was available, non of this problems were present.

I would start to find out the problems step by step.
First of all start a web browser on the same machine where httrack is
running and enter in the browser

What happens?

Second thing is I would check the firewall if you opened port 8080 if you
want to access the page from another machine.

PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.1 | GeForce
9600 GT | 4GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
ION | 3GB Ram

Thanks for the quick reply Martin_Helm. I tried your first option “localhost:8080” and to my surprise webhttrack launched. This was such a shock to me that I actually shook head in disbelief. I ran the first option 4 times same result.

Concerning the second option “checking if port 8080 is opened in the firewall”, I’m afraid I don’t know how to go about it. openSUSE yast tool is brilliant but the firewall utility is confusing to me. Its a little different to what I was used to in Fedora. Please guide me through on how to carry out the second option.

Thank you very much.

Before we go to the details of the firewall.
If you are behind a router, the easiest solution for the monet is simply
disable it. You can do it on the first page of the firewall settings.

Otherwise open the firewall settings. Look at the left - you will see
“Allowed Services” click on that.
In the screen you see now there is an “Advanced” button (at the bottom
Click it - in the field TCP Ports type 8080
Click ok - click next - finish.

If it still does not work afterwards you have a problem with resolving your
computer name in the network.

PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.1 | GeForce
9600 GT | 4GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
ION | 3GB Ram