webcam problem Logitech, Inc. OrbiCam

after upgrading to opensuse11.1, my webcam is not working anymore.
iam using GNOME.

root:~/Desktop>lsusb

Bus 001 Device 002: ID 046d:0896 Logitech, Inc. OrbiCam

it was working before i upgrade .

my laptop is Acer Aspire 5630

any ideas?!

BTW iam not a professional in linux.
iam a user since about 3 months only
so explain the way to solve this problem please

It appears your web cam uses the gspca kernel module, which is now included with openSUSE-11.1 as a provided kernel module. So theoretically, your web cam should “just work” with 11.1.

Unfortunately, from what I have read/experienced is the implementation of this module in the 11.1 kernel was less than satisfactory, and support for a number of different web cams previously supported under the gspca module/driver has been dropped.

The solutions that are available (for such web cams that don’t function in the kernel provide gspca) are not one’s fit for a new user, and are likely difficult for an average user. One needs advanced knowledge to perform a custom compilation of the gspca (to replace the module provided with the kernel) in order to proceed and try a different solution. I have seen no suitable rpms prepackaged (as everyone had expected the module provided with the kernel to work).

IMHO your best bet is to raise a bug report on openSUSE, although it maybe closed in lieu of an upstream kernel problem.

WOW
any simple ideas?!!!

As noted:

You could check to see if the gspca kernel module is loaded.

What does:
lsmod | grep spcagive?

If it is loaded, then there is nothing further I can suggest OTHER THAN WRITE A BUG REPORT, given your current level of Linux knowledge. You will need to learn more first.

elkhedewy@Elkhedewy-Host:~> lsmod | grep spca
gspca_vc032x 17276 0
gspca_main 19940 1 gspca_vc032x
videodev 31236 1 gspca_main
usbcore 167276 6 gspca_vc032x,gspca_main,usbhid,uhci_hcd,ehci_hcd

so how to report a bug?
and is this a bug?

You can write bug reports on openSUSE here:
Submitting Bug Reports - openSUSE

I believe the bug report is your Oribcam web cam of this identification:
Bus 001 Device 002: ID 046d:0896 Logitech, Inc. OrbiCam
should work under the gspca driver/kernel module, where that kernel module is now included in the openSUSE-11.1 2.6.27 kernel. However even though you have the gspca kernel module loaded, the web cam does not work.

… (however, you should confirm one more time it does not work. Did you try various web cam apps, such as kopete, amsn, cheeze, wxcam, etc … ). ?

i tried to open the webcam on skype video test, and kopete but nothing happened.
anyway iam gonna report now
and thank you for useful help

Hi,

There is also a quickcam-kmp-default from repo-oss and quickcam-kmp-pae from repo-oss depending
on what kernel you are using. You can try installing those I mentioned and try if it will give you a black screen in kopete. If it shows a black screen it looks like your webcam is detected. If that is the result try installing the libv4l from packman repository. When you install the libv4l from packman, to make it work, there is a work around and this was discussed in one of the threads in this forum.You have to edit the command of the application you wish to use. For example you want to open kopete you have to add this line:
env LD_PRELOAD=/usr/local/lib/libv4l/v4l1compat.so <your application> so it will look like this,
env LD_PRELOAD=/usr/local/lib/libv4l/v4l1compat.so kopete.
To make the line be permanent in the application that you are using for your webcam. If you are using kde you can right click the kde menu and click the editor and look for the application and edit to add the lines mentioned.

For reference this is the thread that explains this method.
Mini HOWTO for WEBCAMS (gspcav driver) - openSUSE Forums

I also have a thread in this forum regarding my webcam ,you may read it and might find some information that can be useful in diagnosing your webcam problem.
.HP 2-megapixel webcam on opensuse 11.1 - openSUSE Forums

i tried to report the bug but it asked about a number and i don’t have one.
anyway
this topic
Mini HOWTO for WEBCAMS (gspcav driver) - openSUSE Forums
made a change in the webcam , but it still work with some errors
so please take a look and tell me what to do

now the webcam like that:

http://www.6rp.net/upload/download/d61b08d866213b57a6c7d05974707635/Screenshot.gif

http://www.6rp.net/upload/download/ead99d560ddac7e724f617f4ca5c94a8/Screenshot-1.gif

any help?!

i’ve removed the libv4l

and tried to open cheese from terminal to see the error
and here it is:

elkhedewy@Elkhedewy-Host:~> cheese
The program ‘cheese’ received an X Window System error.
This probably reflects a bug in the program.
The error was ‘BadAlloc (insufficient resources for operation)’.
(Details: serial 58 error_code 11 request_code 140 minor_code 19)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)

i’ve removed the libv4l

and tried to open cheese from terminal to see the error
and here it is:

elkhedewy@Elkhedewy-Host:~> cheese
The program ‘cheese’ received an X Window System error.
This probably reflects a bug in the program.
The error was ‘BadAlloc (insufficient resources for operation)’.
(Details: serial 58 error_code 11 request_code 140 minor_code 19)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)

I did this and in Kopete the configuration after two times starting it showed the cam. However, any chat sessions would not open the cam, nor could the person on the other end start a cam session. This was using Kopete in KDE 4.2. Kopete in KDE3.5.10 still refused to even config the cam, which worked fine in 10.3 and 11.0. I am also using Logitech Cam, Communicate STX and gspca module 2.2 loads without error on boot.

elkehedewy,
I saw the images from your link.
If you really wanted to make it work, maybe the last resort is to compile the driver.

I can’t comment on that issue. We are using different webcam and the driver, It is not the driver supplied from open suse repository, I compiled it from the source.

please tell me how to compile it ?

any update?

I don’t know. What is the number of the bug report you raised?

Hi,

I have been away and it is only now I got to drop-by in the forum. I am not keen on compiling but was force to do so just to make my webcam work. First thing first the method I did is a little bit different from what is found on how to compile the webcam driver in the instruction from the site.
I change the method for I feel that in case I borked or reinstall my computer’s operating system in the future I can save the rpm package that I myself created out from the source to not make me go back once again to zero. Hopefully I did the right thing or maybe if there is someone here who is more knowledgeable I am open to advise to rectify it.

As one of the moderator noted in post #2 and I quote “The solutions that are available (for such web cams that don’t function in the kernel provide gspca) are not one’s fit for a new user, and are likely difficult for an average user. One needs advanced knowledge to perform a custom compilation of the gspca (to replace the module provided with the kernel) in order to proceed and try a different solution. I have seen no suitable rpms prepackaged (as everyone had expected the module provided with the kernel to work).” Having said that please do this at your own risk

The tools or rpm packages you will need to compile is available in the opensuse repositories. You will need to install all of those via yast2. These are the prerequisites that you need:
1.make
2.checkinstall (option if you want to create your own rpm)
3.gcc -The system GNU compiler.
4.You will also need the development package to build the driver but I can’t remember it on top of my head, but during the make stage if it complain and throws errors you will be able to trace the missing link and maybe you can post it here for someone who will immediately notice might guide what to do next.

Where to get the source tarball;
This is the link where to find the souce: ~jfrancois/gspca: Summary](http://linuxtv.org/hg/~jfrancois/gspca/)
When you get to that page, on top you will see this:
projects / ~jfrancois/gspca / summary
summary | shortlog | changelog | tags | manifest | bz2 | gz
You have to click the bz2 and download it in your download folder. I am assuming that your machine has already an application to untar the source you have downloaded. To make it easier for you to work with your compiling make a new folder in your /home/user and name it as you wish and transfer the downloaded source and untar it. If you are doing it via gui, mouse right click and extract is the command using the mouse.

For the instructions please visit this link: Jef Moine
and you will find the README which is this:http://moinejf.free.fr/gspca_README.txt
This is the part of the README you should go to the link and read the whole part for more helpful instructions.


                        gspca v2

Important note

        The source of the driver gspca version 2 is included in
        the current Linux kernel (2.6.27).

        If you have problem with your webcam, you may get newer
        versions from Mercurial source code management system at:

        stable version:
                http://linuxtv.org/hg/v4l-dvb

        development version:
                http://linuxtv.org/hg/~jfrancois/gspca/

Getting the source

        You may either get a tarball or the full mercurial repository from
        the previous locations.

Generation

        - the first time:

                - remove from the kernel all gspca v1 or other webcam stuff
                  which may conflict.

                - don't forget to remove the modules 'gspca_xxx.ko'
                  installed in '/lib/modules/.../misc/' by the previous
                  gspcav2 tarball distribution.

                - take care of the modules loaded at startup time
                  and included in the initrd.

                - go to the tarball / repository root.

                - copy the '.config' of your kernel (usually
                  '/boot/config-2.6.xx-xx-yy') to the directory v4l/.
                  Example (from the mercurial root directory):

                        cp /boot/config-2.6.23.12 v4l/.config

                - do a 'make xxxconfig' (xxx depending on your taste -
                  it may be 'config', 'menuconfig', 'xconfig' or
                  'gconfig'.

                - if you have not the full sources of the kernel, the
                  previous command will fail. In this case, manually edit
                  the file 'v4l/.config' adding:

                        CONFIG_USB_GSPCA=m
                        CONFIG_USB_GSPCA_xxx=m

                  where xxx is the name of the subdriver handling your webcam.
                  (look in the file
                        <hg_root>/linux/Documentation/video4linux/gspca.txt)

        - do
                make

        - and, as root:
                make install

Take note that to copy the .config of your kernel you have to be root… If the command line sounds cryptic, you can su to root and browes to /boot using konqueror or dolphin and copy and paste to the directory mentioned. and follow the rest as mentioned in the instruction.

If you want to have an rpm package and wish to keep it

-do
make
and as root:
checkinstall

Note using check install it will create an rpm package in /usr/src/rpm/packages/rpms
Please have a look in that directory and see the folder where to direct your created rpm version eg: i386, i58c etc.

If this sounds complicated I advise you to do a research of more pointers in the net or in this forum for more understanding.

Hope this one will help you to start with your compiling.

tsandu

umm… Why go through the trouble. If it was working before you upgraded your OS, why not just put the version that worked back on. The idea of having the latest and greatest is flawed when it comes to linux, The latest and greatest is usually more buggy than slightly older versions. All to often, having the latest and greatest takes you from a cutting edge system to a bleeding edge system. This is fine for experienced Xers, but newbies are better off staying on the cutting edge side of things. Unless you had a valid reason for upgrading, I would really suggest downgrading back to what worked.

i just know that lately :S

but i still trying to get it work, but if i failed i will downgrade to suse11
it was good for me

and thank you all for helping,
by the way … i still don’t know how to compile and i didn’t understand the steps above
sorry all but iam a new user so just explain it with details please