Webcam openSUSE 12.1

I can’t seem to activate the repo for webcams. I’m using a Sony Vaio Laptop with a built in mic and webcam. In Skype the mic works, but not the webcam. How do I resolve this?

Using openSUSE 12.1 64bit. KDE.

Feel free to ask for further information.

Have you actually tested it in kopete
Or tried the google chat/video plugin if you use gmail?

ok, … please what webcam?

I believe there is more than one Sony Vaio laptop. And there is also likely more than one different webcam in the many Sony Vaios.

If you read the openSUSE webpage on webcams (which I found by typing ‘openSUSE webcam’ ) I note right at the very top of that page it states:

In order to determine what webcam driver is applicable to your webcam, you should check to see what the “device ID” is in your webcam. You can do that by typing in a terminal:


I took the extra time to type the above to explain the easy way to find things in openSUSE. Hopefully it is helpful and not a source of irritation to see how users like myself go about finding this information.

So please if that openSUSE webpage on webcams has insufficient guidance, then post here the relevant output line of ‘lsusb’ so we can see exactly what webcam is in your Sony.

Good luck !

Thank you for the reply. Sorry for the laziness of that post I was in a rush last night. Now I can take the time to study it.

Once again thanks.


"chrispche@linux-v4n2:~> lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 05ca:1839 Ricoh Co., Ltd Visual Communication Camera VGP-VCC6 [R5U870]
Bus 007 Device 002: ID 044e:3011 Alps Electric Co., Ltd
Bus 007 Device 003: ID 044e:3010 Alps Electric Co., Ltd Bluetooth Adapter
Bus 007 Device 004: ID 044e:3013 Alps Electric Co., Ltd
Bus 007 Device 005: ID 044e:3012 Alps Electric Co., Ltd
chrispche@linux-v4n2:~> "

I think I could solve this myself, however is there a problem with the webcam drivers repo for 12.1 at the moment? I can’t access it. If so I can wait.

What do you see in Hardware info
My eg: SUSE Paste


As you can see the Richo camera is an unclassified device. Whatever that means? This camera worked on 11.4.

ETA: Sorry the screenshot is a little bit low res, but you can just make it out.

It would have been better if you could have expanded the tree on the device
Please use susepaste and we’ll get a better image
SUSEPaste - How to use it - Blogs - openSUSE Forums

Is this OK?

SUSE Paste

What I quoted above is your webcam.

The lsusb tells you it is an r5u870, which IMHO means you need an r5u870 driver. …

Now I do not know if that driver comes with the kernel. Possibly not. In which case if you search here for the r5u870 webcam driver you will see some users have packaged this for openSUSE12.1.

So in that search link we have located a bunch of r5u870 drivers, most of which are NOT for you. And we are assuming the r5u870 webcam driver is not packaged with your kernel, so then the 1st thing to do is check your kernel version, because you will need a driver that works with your kernel. Type:

uname -a

that will tell you your kernel. Lets say it is kernel-default-3.1.0_1.2 (or something like that with ‘default’). [If it is desktop then you need the r5u870-kmp-desktop rpm … ]

Then looking at the link I provided you would install r5u870-kmp-default-0.2a_k3.1.0_1.2-1.2.x86_64.rpm (where note the kmp-default-k3.1.0_1.2-1.2 in that file name should be consistent with your kernel version). Install that rpm.

Reboot after installing that and test your webcam.

Thanks for your time. openSUSE has the most friendliest forums. The output is:

"chrispche@linux-v4n2:~> uname -a
Linux 3.1.0-1.2-desktop #1 SMP PREEMPT Thu Nov 3 14:45:45 UTC 2011 (187dde0) x86_64 x86_64 x86_64 GNU/Linux
chrispche@linux-v4n2:~> "

Does that help?

On 2011-12-09 22:56, oldcpu wrote:
> If you read the ‘openSUSE webpage on webcams’
> (

In that page, section “Test your webcam” it says to use kopete or gqcam.
Kopete fails to see my camera, and gqcam is nowhere to be found, unless the
package has another name.

Mine is:
ID 0458:7066 KYE Systems Corp. (Mouse Systems)
iManufacturer 1 KYE
iProduct 2 Acer Crystal Eye Webcam

integrated in my acer monitor. It is not listed in
<>. And the link to
is broken (“check the UVC Webcams page”).

It works with the google plugin, sometimes.

I want to test it in my 12.1 test system, but cheese crashes in the
fallback gnome mode (known bug), and I don’t have any other tool installed,

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Thank you greatly for your help admins. It’s all working now. Now my kids is South Africa can see there daddy. You don’t know how much that means to me, help greatly appreciated.

Thank you.

It’s handy if you can list the steps that made it work

Basically I went here: Search Results and downloaded the… and this is the important part. I downloaded the desktop file “r5u870-kmp-desktop” then the default file, “r5u870-kmp-default”. Installed both of them rebooted and voilà, it worked. Also going back through the thread I executed various commands to see what hardware I actually had.

These are the commands:

“lsusb” to find out if Linux sees a camera device.

and then…

“uname -a” to find what kernel I was running. Went to the link above and installed the relevant 64bit rpm.

ETA: Sorry I’m not the best at explaining things.