Webcam on Skype

Hi everybody!

I`ve searched on the forum about my problem, but I cannot find an answer to my problem… I have a Creative Live! VF0400 Pro webcam, witch video is not working on Skype Beta 11.2

The audio/video is working perfecty on openSUSE 11.2, but has problems with Skype… how to make it run on Skype?

In ubuntu there is a command, LD_PRELOAD=/usr/lib/libv4l/ skype but in openSUSE is not working…

Thank you and best wishes!

LD_PRELOAD=/usr/lib/libv4l/ skype is not working… (in the command prompt, after Skype loads, when I click Options → Video devices → Test button Skype crashes and on the command line I have the output Aborted or Segmentation fault.

Please help me.

Solved the problem, thank you!

Instead of using the script, that doesn`t work, I got HCL/Webcams driver from GSPCA Video4Linux 2, found on

So, if anybody faces the same problems with Skype webcam, install GSPCA driver from

Thank you!

I have a thread like this on the forums too.
A starting point for any webcam issue should be HCL/Web Cameras.

I think that the command works with UVC webcams only. It worked with mine, Microsoft LifeCam NX-6000, which is on the UVC list.

I think openSUSE is the only one I’ve gotten video to work with in Linux (using this command) so far.

If you have installed libv4l, the command LD_PRELOAD=/usr/lib/libv4l/ skype work also in Ubuntu!

Actually, this worked for me on Ubuntu, but not on openSUSE.

In Ubuntu is enough to run the script, in openSUSE you need to install HCL/Webcams driver from GSPCA Video4Linux2.

I start skype through a script that I creatively called “skype2” and placed in my ~/bin directory:

export LD_PRELOAD=/usr/lib/libv4l/

Works fine on 11.2 64-bit, both gnome and KDE 4.3.

Are you able to add it to the main menu slab in Gnome?

Yes. Control Center -> Main Menu

I actually just add it to

Control Center -> Startup Applications

to make it start automatically when I log in.

Obviously, you should try skype2 from a terminal to verify that it actually works.

Perhaps related, you should run gstreamer-properties and verify that video is set to “Video for Linux 2 (v4l2)”.

Perfect, that worked.

I went into “More Applications”, pulled up Skype or Cheese, right-clicked the icon and went into Properties.

I don’t know why I didn’t see it before, but I was able to add the code to the execute command.

The favorites shortcuts needed to be refreshed but that was without any effort really, and it worked!

I prefer it not starting up automatically, it brings too many flashbacks of my work computer that takes a good 10 minutes or more (no joking) to boot up into a state where I can send the morning email (my boss wants us to send a “Good Morning” email when we get in and a goodbye email when we leave).