webcam not connecting

I have read lots of the webcam threads before posting this my problem
Cannot get picture from usb webcam
tested it by installing on a windows xp machine with its drivers for windows that came on mini cd
it works very well.
my machine 18 gig Celeron. 1GB ram 500g hard drive.
Running open Suse 11.2 with KDE#.% desktop.

pluged cam in my usb
Skype reported no video detected.
Ran Yast hardware report.
showed device USB20 camera
model microdia USB20 camera
UDI /usb devices/_c45_6270
Vendor Microdia
To confirm this info came from the cam I unplugged it and ran hardware report again . No cam shown.
Plugged backin and report showed info as above agaibn so I know info comes from the cam

Searched SUSE software repositories found drivers sn9c20x four versions. for Microdia webcams.
Driver decription includes webcam model 0c45:6270 listed among many others. Tried installing default version and it and others resulted in yast conflict error. PAE version installed OK but yast added installation of an upgraded kernel to Linux i686

After installing driver Skype showed video detected as the name of the driver vis sn9c20x at /dev/video . Clicking on Skype test video button gets a white screen no image
Had a look at /dev directory and found node video which is a link to another node video0

I installed several webcam programs including cheese and webcam and although I run KDE3.5 I also installed Gqcam a gnome prg for webcam.
all programs show nothing from the camera except gqcam
Gqcam has ten vertical bars seperated by vertical black bands.
In the bars there is some sort of image. I can have things moving around in there by waving my hand in front of the cam
I believe what I am seeing is a badly out of focus image in black and white no color
I conclude that the cam has to have settings loaded but not cheese or any of the other prgs have provision for loading settings. Some program would have to load the settings to the cam at strart up? Wich program and where would I put the settings? help please. I most specifically want cheese and skype to see the cam
A startup debug log of my system shows the webcam driver loaded. to dev/video0 but nothing else.There is a later mention of the webcam on USB port being detected.
I wondered if there was a connection from usb to Video0 missing but then Gqcam would not see anything ???
llewellyn Lee

Looks like you are there.

Try open a terminal and paste this command just to see if it will work.

env LD_PRELOAD=/usr/lib/libv4l/ gqcam -s

Thankyou Tsandu
I logged in as root opened terminal and pasted the command you gave.
Result was that Gqcam started but also error message as follows
ERROR: object ‘/usr/lib/libv4l/’ from LD_PRELOAD cannot be p reloaded: ignored.

I now had the terminal still open and Gqcam scren also .
To see my blurry image I have to adjust the slider controls on Gqcam first increasing brightnes.then I did contrast then color with each action
Immediately on terminal appeared responses
ioctl (VIDIOCSPICT): Device or resource busy
ioctl (VIDIOCSPICT): Device or resource busy
ioctl (VIDIOCSPICT): Device or resource busy
Segmentation fault
The segmentation fault came on the terminal when I shutdown gqcam by clicking top left corner X of its screen.
Significant is that when I wave my hand upward the image movement goes down . My very odd image from the cam must thus also be upside down .
Just by the way in my first post I did not mention that I changed the GROUP of /dev/video0 to be Video and also my user login to be a member of video group. I hope that was sufficient to ensure my problem is not related to permissions.